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Introduction

You’ve collected all of these wonderful 
BSE/EDX images, so Now What?!

This session will introduce the basic concepts on how to 
perform Image Processing and Image Analysis in order 
to qualitatively, and, more importantly, quantitatively
characterize your data. 



Image Processing and Analysis

• We will be demonstrating a simple method for quantitative 
analysis using two free software packages:

• ImageJ http://imagej.nih.gov/ij/
 ImageJ was developed by NIH. It is open source and operates in Java, which has 

allowed for extensive usability and accessibility through the creation of thousands of 
plug-ins. 

• MultiSpec https://engineering.purdue.edu/ biehl/MultiSpec/ 
 MultiSpec was developed at Purdue University for processing of hyperspectral data. 

Initially created for analysis of images of the Earth from satellite data, it is widely 
applicable to any stack of spectral images, such as EDX maps or medical images. 

• In this session, we will show a demonstration of the method. At 
the start of Practicum 5, we will do a slower demonstration where 
you can follow along step-by-step on your computer. 



Step-by-Step Analysis

 See these references for more detailed instructions:

 Stutzman, P.E., Feng, P., and Bullard, J.W. (2016). “Phase analysis of portland 
cement by combined quantitative X-ray powder diffraction and scanning electron 
microscopy,” Journal of Research of the National Institute of Standards and 
Technology, 121, 47-107. http://dx.doi.org/10.6028/jres.121.004

 Stutzman, P.E., Bullard, J.W., and Feng, P. (2015). Quantitative Imaging of Clinker 
and Cement Microstructure, NIST Technical Note 1877, U.S. Department of 
Commerce, Washington, D.C. http://dx.doi.org/10.6028/NIST.TN.1877

 Example: SRM2688



Step-by-Step Analysis

 Step 1. ImageJ

1. Open BSE and EDX images in ImageJ and Tile (Window -> Tile).

 Typically just look at BSE image and EDX maps of Al, Mg, K, Na, and S
 You can open images by dragging files from the folder to ImageJ. 

2. Adjust each image’s contrast and brightness (Image -> Adjust -> 
Brightness Contrast) to see the background noise more clearly

 Just move the “Maximum” slider (2nd bar from top) in B&C box

3. Subtract background noise (Process -> Math -> Subtract). Use the 
preview check box in the Subtract window to interactively adjust the 
noise level selection. Focus on removing the majority of the noise. 

 Filter out any additional noise (Process -> Noise -> Despeckle)

 Typically, if your data are high quality, you do NOT need to use any filters

4. Save (File -> Save As -> TIFF) the modified images with an “M” or 
other identifier so that the original (unmodified) image is not over-
written. (Note: You may need to convert images to 8 bit)  



Step-by-Step Analysis

2. Link the modified EDX images 
to the BSE image. Use (File -> 
Open Image) and select “Link 
to active image window” and 
individually select each 
modified EDX image. Write 
down the order in which you 
link each element (e.g., 1=BSE, 
2=Al, 3=Mg, 4=S...) Click 
Cancel to complete linking.  

3. Save this linked image set 
(Processor -> Reformat -> 
Rectify Image). Be sure to 
retain the .LAN extension. 

 Step 2. MultiSpec

1. Read original (or modified) BSE image into MultiSpec (File -> 
Open Image). Check the “Multispectral Type” box.



Step-by-Step Analysis

 Step 2. MultiSpec

4. Close all images. Open (File -> Open Image) the .LAN image 
set to confirm everything is correct. A window called 
“Multispectral Display Specifications” will appear; this is where 
you can assign color channels (RGB format) to each image. 
Use (Processor -> Display image) to switch between channels. 

 For Clinkers, assign RGB channels to correspond to:

 R, G, B = BSE, Mg, Al -> this is most useful to differentiate alite, belite, aluminate, 
ferrite, periclase, lime, and voids

 R, G, B = BSE, S, Al -> this is useful to see sulfates

 [Also: R, G, B = BSE, S, (Na,K) -> if you want to differentiate sodium sulfate 
(aphthitalite) from potassium sulfate (arcanite)]



Step-by-Step Analysis

 Step 2. MultiSpec

Brightness and Contrast 
adjusted BSE image

Image in MultiSpec after Item 4: 
RGB channels corresponding to 

BSE, Mg, Al

Alite (light red)

Belite (dark red)

Ferrite (pink)

Aluminate (blue)

Voids (black) Periclase (green)



Step-by-Step Analysis

 Step 2. MultiSpec

5. Set up the training classes (Processor -> Statistics). Accept the 
default options in “Set Project Options” window. 

 In the “Class Designation” window, make sure “Class: ‘New’ ” is selected. 
Select a region of the image corresponding to a certain phase, then click 
“Add to List” and name the phase accordingly. Repeat for all other phases:  

 For clinker, assign: alite, belite, aluminate, ferrite, periclase, alkali sulfates, voids

 For cement, assign: same as clinker, may also have gypsum and limestone

 Add training classes by selecting the class from the list and then specify 
“Add to List.” Adding more training pixels will help train MultiSpec to identify 
phases. 

 Following this order will help with implementation in other programs later, 
such as VCCTL and THAMES:



Step-by-Step Analysis

 Step 2. MultiSpec

Item 5: Assigning training fields



Step-by-Step Analysis

 Step 2. MultiSpec

6. Classify the data (Processor -> Classify). 
 Use the “Minimum Euclidean Distance” algorithm 

 Check the box “Write Classification Results” to disk and be sure to check 
that the file path is correct and that the file has .GIS extension 



Step-by-Step Analysis

 Step 2. MultiSpec

7. Save the work as a Project. This way you can go back and 
change the training fields, try different classification algorithms, 
etc. 

8. Save the .GIS file as a .TIFF file. This will retain the color 
assignments. Do NOT use .JPG as this will not retain the color 
assignments correctly. 

9. Open the .TIFF file in ImageJ and save as ASCII file (File -> 
Save As -> Text Image)

 This is so you can have an ASCII file with the indexed phases for input 
to other programs (such as MicroChar)



Another ImageJ Technique
 Münch, B., Martin, L., and Leemann, A. (2015). 

"Segmentation of elemental EDS maps by means of 
multiple clustering combined with phase identification,” 
Journal of Microscopy, 260 (3), 411-426. 
doi:10.1111/jmi.12309 

 Get the ImageJ plugin at: http://imagej.net/Xlib

• Input the EDX maps 

• The program will look at the 
chemistry at each pixel and 
use clustering algorithms to 
group those pixels into an 
unknown phase

• Unknown phases are then 
compared to the chemistry of 
known phases to predict 
what that group of pixels 
most likely corresponds to



What if I have too many images?

• ImageJ and MultiSpec work very well, but they can be tedious if 
you have a lot of images 
• Consider Zhao and Darwin (1992) argued that you may need upwards of 

150 BSE images to be 95% confident in your quantification of uhydrated
cement content at 1000x magnification

• A lot of the tedious button-clicking in ImageJ and MultiSpec can 
be automated (or at least semi-automated) in platforms like 
MATLAB
• Use MATLAB to:

 Successively or iteratively read in multiple (or all) files

 Automatic/Semi-automatic greyscale (or other) thresholding 

 Automatic collation and statistics of data from all images

 Automatic image properties (e.g., shapes, geometries, distances)

 More than likely whatever else you can think of!!

Zhao H. and Darwin D. (1992) Quantitative backscattered electron analysis of cement paste. Cem. Concr. Res. 22, 695–706.



Why MATLAB?

• A programmable computing environment optimized for matrix 
manipulation and computing
• MATLAB = Matrix Laboratory

• Images are just matrices! 

169 168 172 120 158 169 168 165
169 171 143 148 169 165 164 165
170 167 145 163 168 169 167 166
168 138 150 152 163 168 168 168
165 134 164 184 168 167 167 168
163 140 184 187 166 166 165 168
141 150 170 151 159 167 162 166
148 151 126 122 157 167 166 168
153 144 121 118 149 167 168 169
136 133 120 120 137 162 167 168
172 176 178 185 175 165 168 168
144 158 171 194 197 169 166 166
154 159 162 162 179 175 165 165
164 160 167 166 163 179 166 164
169 155 165 167 164 168 162 165

8-bit greyscale 



Example: Semi-Automated Analysis of ITZ Characteristics 

Remove
Aggregate

Porosity
Threshold

Brand A. S. (2015) Interfacial transition zone composition and bonding in cementitious systems with asphalt-coated 
particles. PhD Dissertation, University of Illinois, Urbana, IL.



Example: Semi-Automated Analysis of ITZ Characteristics 

Automated 
morphological 
filtering



Example: Semi-Automated Analysis of ITZ Characteristics 

100 μm



Example: Semi-Automated Analysis of ITZ Characteristics 



Example: Semi-Automated Analysis of ITZ Characteristics 

Collate all of the 
data to get ITZ 
distributions 
averaged over 
50-60 images

A.S. Brand, J.R. Roesler, Bonding in 
cementitious materials with asphalt-
coated particles: Part I – The interfacial 
transition zone, Constr. Build. Mater. 
130 (2017) 171–181. 



Example: Semi-Automated Analysis of ITZ Characteristics 

Automated calcium 
hydroxide morphological 
analysis



Example: Semi-Automated Analysis of ITZ Characteristics 

Publications on this semi-automated method as applied to:

 Reclaimed asphalt pavement aggregates
 A.S. Brand, J.R. Roesler, Bonding in cementitious materials with asphalt-coated 

particles: Part I – The interfacial transition zone, Constr. Build. Mater. 130 (2017) 
171–181. doi:10.1016/j.conbuildmat.2016.10.019.

 A.S. Brand, J.R. Roesler, Bonding in cementitious materials with asphalt-coated 
particles: Part II – Cement-asphalt chemical interactions, Constr. Build. Mater. 130 
(2017) 182–192. doi:10.1016/j.conbuildmat.2016.10.013.

 A.S. Brand, Interfacial transition zone composition and bonding in cementitious 
systems with asphalt-coated particles, Doctoral Dissertation, University of Illinois at 
Urbana-Champaign, 2015. http://hdl.handle.net/2142/88969.

 Recycled concrete aggregate
 A.S. Brand, J. Roesler, Interfacial transition zone of cement composites with 

recycled concrete aggregate of different moisture states, Adv. Civ. Eng. Mater. 
7 (2018) 87–102. doi:10.1520/ACEM20170090.

 Steel furnace slag aggregates 
 A.S. Brand, J.R. Roesler, Interfacial transition zone of cement composites with 

steel furnace slag aggregates, Cem. Concr. Compos. 86 (2018) 117–129. 
doi:10.1016/j.cemconcomp.2017.11.012.



Recommended References 

Overview Documents with Useful Step-by-Step Instructions for ImageJ and MultiSpec
 Stutzman, P.E., Feng, P., and Bullard, J.W. (2016). “Phase analysis of portland cement by combined quantitative X-ray 

powder diffraction and scanning electron microscopy,” Journal of Research of the National Institute of Standards and 
Technology, 121, 47-107. http://dx.doi.org/10.6028/jres.121.004

 Stutzman, P.E., Bullard, J.W., and Feng, P. (2015). Quantitative Imaging of Clinker and Cement Microstructure, NIST 
Technical Note 1877, U.S. Department of Commerce, Washington, D.C. http://dx.doi.org/10.6028/NIST.TN.1877

 Stutzman, P.E. (2012). “Microscopy of clinker and hydraulic cements,” in Reviews in Mineralogy and Geochemistry, 74, 101–
146. doi:10.2138/rmg.2012.74.3.

Helpful How-To and Troubleshooting Guide
 Winter, N.B. (2012). Scanning Electron Microscopy for Cement and Concrete, WHD Microanalysis Consultants: Woodbridge.

Overview Document on Theory and Literature
 Scrivener, K.L. (2004). “Backscattered electron imaging of cementitious microstructures: Understanding and quantification,” 

Cement and Concrete Composites, 26 (8), 935–945. doi:10.1016/j.cemconcomp.2004.02.029
 Diamond S. (2001). “Considerations in image analysis as applied to investigations of the ITZ in concrete,” Cement and 

Concrete Composites, 23 (2-3), 171–178. doi:10.1016/S0958-9465(00)00085-8

Other Useful Image Processing Techniques and Tools
 Wong, H.S., Head, M.K., and Buenfeld, N.R. (2006). “Pore segmentation of cement-based materials from backscattered 

electron images,” Cement and Concrete Research, 36, 1083–1090. doi:10.1016/j.cemconres.2005.10.006.
 Wong, H.S., and Buenfeld, N.R. (2006). “Euclidean distance mapping for computing microstructural gradients at interfaces in 

composite materials,” Cement and Concrete Research, 36, 1091–1097. doi:10.1016/j.cemconres.2005.10.003.
 Münch, B., Martin, L., and Leemann, A. (2015). "Segmentation of elemental EDS maps by means of multiple clustering 

combined with phase identification,” Journal of Microscopy, 260 (3), 411-426. doi:10.1111/jmi.12309 (and also see 
http://imagej.net/Xlib for accompanying software and ImageJ plug-in)


