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Disclaimer 
 
Certain trade names or company products are mentioned in this document to specify 
adequately the software used for developing and supporting the Graphical User Interface 
for Project 25. In no case does such identification imply recommendation or endorsement 
by the National Institute of Standards and Technology, nor does it imply that the software 
used is the best available for the purpose. 
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1 Overview 
There are two parts to the Project 25: Inter-RF Subsystem Interface (ISSI) model: 
 

1) The server program that models the behavior of the ISSI protocol(s), along with the 
server that allows interaction with the graphical user interface application (GUI). 

2) The GUI allows for entering network topology configuration information destined 
for the server program; and it processes the output files from the server program to 
playback the simulation scenarios to the user. 

 
The server program is meant to be used as is. This program simulates the behavior of the 
P25 ISSI protocol [1]. 
 
The GUI performs two distinct tasks: 1) It allows for designing and configuring 
simulated networks into projects that are used as inputs to the server program; 2) it 
processes the output files from the server program and presents the results in various 
forms to the user. Its playback mechanism also allows for visualizing the replay of the 
simulation projects via time lines. 
 
This document covers the graphical user interface. The GUI is a window based 
application written in the Java programming language; it is used for creating and 
configuring P25 ISSI network scenarios. These scenarios are saved as simulation projects 
and their files are transmitted to the simulation server as input files to the server program. 
The server program generates output files from running the simulation projects; the GUI 
retrieves the output files from the simulation server, replays and presents the results to the 
user. 
 
Section 2 contains a quick start guide to using the GUI. Section 3 provides an overall 
description of the GUI, followed by sections describing in depth details about specific 
panels offered by the GUI (Topology, Topology Configuration, Statistics, Media, Status 
and FileViewer panels). Section 10 explains the list of open projects. Section 11 explains 
how to run the simulation. Section 12 contains a description of the statistics that are 
collected and the methods used to compute these statistics. Section 13 explains versions 
and compatibility. Section 14 lists the supported shortcut keys or key-combinations. 
Section 15 lists the acronyms and section 16 lists references. 
   
Appendix A provides some background information about networks, their compositions 
and how to build a network using the ISSI Network Simulation Tool and the GUI 
Application. 
 
Appendix B provides an audio usage guide that describes how to use the audio tool to 
convert audio files into audio data, and how the audio data can be used in simulation 
projects. 
 
Appendix C provides a list of common error messages with possible causes. Appendix D 
lists software tools used with the GUI and Appendix E lists the trademarks. 
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2 Quick start 
 
The ISSI Network Simulation Tool software is written in Java and is supported by 
multiple platforms such as Windows and Linux. The following descriptions are for 
installations on the Windows platform: 
 
Step 1: 
Start the graphical user interface (GUI) by: 

1) Opening “ISSI Network Simulation Tool” under the “Start->All Programs” menu, 
2) Double clicking on the “ISSI Network Simulation Tool” shortcut icon on the 

desktop, or 
3) Clicking its quick launch icon. 

 
Step 2: 
 
Step 2a:  
Loading an existing project 
 
To load an existing project: 

1) Select “File->Open Project” from the main menu bar, or 
2) Click the “Open Project…” button at the bottom of the GUI, or 

3) Click the open project icon  
 
This will open a browser window that allows for finding projects. Navigate to the 
appropriate directory (e.g., C:\Program Files\ISSI Network Simulation Tool\scenarios) 
and select a project to load. 

NOTE: Projects are marked with a red diamond preceding the project’s name. 
 
Step 2b:  
To create a new project, see the appendix for “Network Primer” for more details. 
 
Step 3: 
Preparing to run a simulation 
 
Step 3a: 
Configure the GUI with the server information (i.e., address and port) by selecting 
“Project->Project Properties” (Ctrl+P) from the main menu bar.
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Step 3b: 
 

Click on the Server button  located on the left hand side of the window to display 
the server information (i.e., address and port) to be configured 
 
Step 3c: 
 

Click on the Simulation button  located in the left hand side of the window to 
display the simulation information (i.e., simulation time and simulation seed, as well as 
debug options) 
 
Step 3d: 
Click the “OK” button to return to the main window 
 
Step 4: 

Click on the “Launch simulation in the server” icon  and authenticate to the server. 
The menu option “Project->Launch Simulation” or the short cut key-combination “Ctrl-
R” can also be used to launch the simulation in the server. 
 
This action: 

1) Transmits the project files from the GUI’s platform to the server, 
2) Runs the simulation in the server, and 
3) Retrieves the output files from the server back to the GUI’s platform. 

 
IMPORTANT: The current project and its files containing the latest topology and 
configuration will be saved to the hard drive when any simulation run is done. If the user 
wishes to keep the original configuration of the project, it is recommended that a copy of 
the original project be saved using the “File->Save As…” function before making major 
modifications then running simulations. However, the user may use the “Edit->Undo” 
function to revert back to the project’s original configuration. 
 
Step 5: 
View results 
 
The statistics window can be opened in the following manner: 

1) Select “Window->Statistics” from the main menu bar 
2) Click on the “Statistics” window tab 
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For more details on the available statistics, please refer to section 12 (Statistics 
Computation Methods). 
 
For a comprehensive description of the layouts and actions available within the GUI 
please read the rest of this document. 
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3 Overall Description of the Application 

3.1 Initial Window 
Figure 1 shows the initial GUI window. The main menu bar is located at the top (File, 
Edit, Project, View, Tools, Windows, and Help). Below the main menu bar is the icon bar 
with an icon for opening an existing project file. At the bottom of the window, there are 
two buttons: “Create Project…” and “Open Project…” 
 

 
Figure 1 – Initial GUI Window 

 

3.2 Main Menu bar 

 

3.2.1 File Pull-down Menu 
The “File” pull-down menu contains the following options: 

• New Project (Ctrl+N): Allows for creating a new project (see section 3.4) 
• Open Project (Ctrl+O): Opens an existing project 
• Close Project (Ctrl+W): Closes the current project 
• Save (Ctrl+S): Saves the current project 
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• Save As: Saves the current project to another directory, using another name, or 
both 

• Exit: Exits the program 

3.2.2 Edit Pull-down Menu 
The “Edit” pull-down menu contains the following options: 

• Undo (Ctrl+Z) 
• Redo (Ctrl+Y) 
• Search (Ctrl+F) 
• Modify/Delete SUs 
• Preferences (Ctrl+L) 

3.2.2.1 Undo/Redo 
In design mode (see section 3.2.4.2), when edits have been done to a project’s 
configuration then those edit actions will be displayed under the “Edit” menu item for the 
user to undo or redo. The number of edits stored for undo and redo is configurable under 
the “Edit->Preferences” menu option. See section 3.2.2.4. 

3.2.2.2 Search 
Used to search the project for keywords in the topology objects’ names and descriptions; 
the results can be limited by selecting the type of objects to be searched (e.g., node, link, 
SU/group, or application). Selecting “Any” will allow for searching for keywords in all 
objects’ names and descriptions. See Figure 2. 
 

 
Figure 2 - Search Parameters 

3.2.2.3 Modify/Delete SUs 
This option allows for processing multiple subscriber units (SUs) to do modifications 
and/or deletions. The term “bulk”, used in this context, represents the group of SUs being 
processed. 
 
Step 1 of 2 allows for choosing SUs by their groups, or by their radio frequency gateways 
(RFGs) (see Figure 3). Once the SUs have been chosen, the “Next” panel allows for 
either modifying the SUs’ properties or for deleting the SUs, see Figure 4. 
 
Step 2 of 2, if SU modifications were chosen from step 1 above then Figure 5 shows the 
“SU configuration” panel that allows for bulk SU modifications. Properties that are 
displayed as “Inherit” indicate that they have different values for the chosen SUs. 
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Properties that are displayed as anything other than “Inherit” indicate that all of the 
chosen SUs share those same values. 
 

 
Figure 3 - Modify/Delete SUs: Selecting SUs 

 

 
Figure 4 - Modify/Delete SUs: Execute option 
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Figure 5 - SU Configuration Window: Modify Mode. 

3.2.2.4 Preferences 
Used to configure default properties for all “new” projects; there are four panels 
(Properties, Server, Simulation, and Maps). 
 
The “Properties” panel (Figure 6) allows for: 

• Configuring the list size for the “Edit->Undo/Redo” feature. 
• Configuring additional image directories that are relative to the installation 

directory of the GUI. Note that background image files and icon image files 
should be stored in these directories. The search order for image files will start 
with the directories configured in this panel followed by the GUI’s default 
“image” directory (i.e., from its installation directory). 
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Figure 6 - VizNet Properties: Properties Configuration 

 
The “Server” panel (same as under the “Project->Project Properties” main menu option) 
allows for configuring the default simulation server’s address and port, as well as whether 
to keep or delete the output files on the server after the simulation run is completed. See 
section 3.2.3.4.2 for more details. 
 
The “Simulation” panel (same as under the “Project->Project Properties” main menu 
option, except the simulation time is not applicable) allows for configuring the 
simulation’s random number generator’s seed, as well as specific debug features. See 
section 3.2.3.4.3 for more details. 
 
The “Maps” panel allows for selecting existing image files, or for creating and importing 
maps for use in projects’ backgrounds. See section 3.2.2.4.1 for more details. 
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3.2.2.4.1 Selecting or Importing Maps 
 

 
Figure 7 - VizNet Properties: Maps Configuration 

 
The “Maps” panel is used to select a map from a set of previously configured and saved 
maps, or to create and import new maps. See Figure 7. 
 

Use the select button  along with the “Select File” dropdown option to open a 
browser window for importing preexisting map image files (.jpg or .png files). These 
types of selected maps are referred to as “user created” maps. 
 
Parameters for a newly selected map image file must be entered before that map can be 
saved to the GUI’s maps database. For “user created” maps, use the “Edit” button to 
update those map’s parameters (e.g., the map’s name and its type). A map of type Global 
Positioning System (GPS) uses the parameters NW longitude, NW latitude, SE longitude 
and SE latitude. A map of type area uses the parameters width and height to configure 
that area (in meters). 
 

The select button  along with the “Google Maps” dropdown option allows for 
creating and importing new map image files via the “Google Maps” feature. Maps that 
were imported using the “Google Maps” feature can only have their names modified, all 
other parameters are static. See section 3.2.5.1.1.1 for more details. 
 
The “Save” button allows for saving the map’s configuration. 
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The “Cancel” button allows for discarding all changes made from the edit session. 
 
The “Delete Map” button allows for deleting the selected map. A pop-up window will be 
displayed to confirm the deletion request. 
 
The GUI’s maps database is keyed by map names, some projects may contain maps that 
are not yet available in the GUI’s maps database, the “Import Map” button allows for 
importing maps into the GUI’s map database. Figure 8 shows the “NewYork-NY-USA 
via satellite image” map highlighted in green indicating that it can be imported. Once the 
green highlighted map is selected, the “Import Map” button will be enabled for import 
purposes. 
 

 
Figure 8 - Importing a Map 

3.2.2.4.1.1 Creating/Importing Maps Using the Google Maps Feature 

From the “VizNet Properties: Maps Configuration” panel, use the select button  
along with the “Google Maps” dropdown option to open the “Google Maps” window (see 
Figure 9). For the “Address or Longitude, Latitude” field, enter the location of interest, 
e.g., “Washington, DC, USA” then click on the “Update” button. Select the desired “Map 
type” from the dropdown choices (roadmap, satellite, terrain or hybrid). Select the 
desired “Zoom” level, e.g., 10 then click on the “OK” button to exit the “Google Maps” 
window. Note that communication with the Google Maps’ servers must be available for 
this feature to function properly. 
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Imported maps must have unique names, otherwise the imported map (with its duplicate 
name) will be presented in the “VizNet Properties: Maps Configuration” panel so that the 
map’s name may be changed. Select the “Save” button to save the new map’s 
configuration to the GUI’s maps database or select the “Cancel” button to discard the 
new map; select the “OK” or “Cancel” button to exit the “VizNet Properties” window. 
 

 
Figure 9 - Google Maps Window for Creating and Importing Maps 

3.2.3 Project Pull-down Menu 
The “Project” pull-down menu contains the following options: 

• Launch Simulation (Ctrl+R) 
• Project Analysis 
• Generate Report 
• Properties (Ctrl+P) 

3.2.3.1 Launch Simulation 
Use this option (Ctrl+R) to launch a simulation run on the server. 

3.2.3.2 Project Analysis 
Available in read-only mode (see section 3.2.4.2), this option loads the “Analysis 
Wizard” to display analysis results for the project. This section covers the various results 
that can be generated. 



 13 

3.2.3.2.1 Load Capacity Analysis Tab 
The load capacity analysis tab shown in Figure 10 displays the statistics about the traffic 
load per link as well as a suggested capacity to meet the load’s criteria for the simulation 
project. There are two parameters available for computing the “Suggested capacity”: 

• The “Bandwidth Limit” defines the maximum percent of the bandwidth that 
should be used to support the load. E.g., use up to 80% of the bandwidth to 
support the load. 

• The “Time Limit” defines the amount of time acceptable for the load to be greater 
than the bandwidth limit. E.g., the bandwidth limit can only be exceeded 0.1% of 
the time. 

 
The “Suggested Capacity” represents the link capacity required so that the traffic load on 
the link will not exceed the “Bandwidth Limit” for a period of time greater than the 
“Time Limit”. 
  
For requirement analysis, enter the appropriate values for the “Bandwidth Limit” and the 
“Time Limit” then select the “Compute” button to generate the results that will update the 
following columns accordingly: 

• The name of the link identified by the source and destination node. 
• The current capacity of the link (in bytes per second). 
• The mean offered load measured from the simulation (in bytes per second). 
• The variance of the offered load measured from the simulation (in bytes per 

second). 
• The suggested capacity that could be used to satisfy the parameters set by the user. 

 
Right-click on a cell in the “Suggested Capacity” column displays a pop-up menu option 
that allows the user to apply the recommended value to the simulation's scenario. 
 
The lower part of the panel shows statistics for the selected link over time. The X-axis 
represents the time of the simulation and the Y-axis represents the offered load: 

• The blue graph displays the offered load. Note that this graph is not continuous 
since it only displays data when there is traffic on the link. 

• The green graph displays the mean offered load. 
• The red graph displays the suggested capacity. 
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Figure 10 - Analysis Wizard: Load Capacity Analysis 

 

3.2.3.2.2 Call Analysis Tab 
The “Call Analysis” tab contains two tabs: “Call Statuses” and “Call Delay” 
 

• The “Call Statuses” tab shows the summary of the call statuses. 
• The “Call Delay” tab shows the distribution of the call setup delays. 

3.2.3.2.2.1 Call Statuses Tab 
The “Call Statuses” tab displays the statuses of the calls that occurred during the 
simulation. This information is provided in three graphical forms contained in their 
respective tabs: “Numbers”, “Percent” and “Pie Chart”. 
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Figure 11 - Call Statuses (Actual Counts) 

 
Figure 11 shows the call statuses using their actual counts from the simulation. 
Successful calls are in green, failed calls are in red, cancelled calls are in orange, all other 
statuses are in blue. The number of calls for each type of status is shown. The Unit-to-
Unit calls are displayed on the left and the Group calls are displayed on the right. 
 
Figure 12 shows the statuses in terms of percentage rather than their actual counts. It 
allows for immediate observation of the percentages of each status for Unit-to-Unit Calls 
and Group Calls. 
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Figure 12 - Call Statuses (Percentage) 
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Figure 13 shows the percentage information using a pie chart diagram instead of a 
histogram. 
 

 
Figure 13 - Call Statuses (Pie Chart) 
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3.2.3.2.2.2 Call Delay Tab 
Figure 14 shows the call delay analysis. “Unit-to-Unit” calls (SU Calls) are displayed on 
the left and “Group” calls that are displayed on the right. The X-axis represents the delay 
time. The red data points indicate the number of calls versus the call delay. The graph 
represents the distribution of the delay. The blue line represents the cumulative 
percentage for the distribution of delays; it always starts at 0% and always ends at 100%. 
Figure 14 shows an example with 90% of the “Unit-to-Unit” calls having setup delays 
lower than 0.5 second. 
 

 
Figure 14 - Call Delay 
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3.2.3.2.3 Packet Analysis Tab 
The “Packet Analysis” graph shows information about the packets going through each 
link. The Y-axis shows the number of occurrences for: 

• Packets sent (indicated in blue) 
• Packets received (indicated in green) 
• Packets dropped (indicated in red) 

 
This graph can be helpful in finding busy or defective. See section 12 (Statistics 
Computation Methods) for details on how statistics are calculated. 
 

 
Figure 15 - Packet Analysis 
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3.2.3.3 Generate Report 
Used to generate a Portable Document Format (PDF) report of the simulation topology 
and/or statistics; there are four panels for selecting the information to be present in the 
generated report. 
 
Step 1 of 4 allows for selecting the topology items to be included in the report. Use the 
plus/minus icons to display more/less specificity. Click the “Next” button to go to the 
next step. See Figure 16. 
 

 
Figure 16 - Generate Report: Step 1 of 4 
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Step 2 of 4 allows for selecting statistical items gathered from the simulation run. Use the 
plus/minus icons to display more/less specificity. If a simulation was not run, then there 
will be no statistics to report. Click the “Next” button to go to the next step. See Figure 
17. 
 

 
Figure 17 - Generate Report: Step 2 of 4 

 
Step 3 of 4 allows for selecting items from the simulation analysis to be included in the 
report. See section 3.2.3.1 for more details about the “Analysis Wizard”. Click the “Next” 
button to go to the next step. See Figure 18. 
 

 
Figure 18 - Generate Report: Step 3 of 4 
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Step 4 of 4 allows for configuring paging and printing options for the report. Click on the 
“Generate” button to bring up a browser window to specify the location and name for the 
report. See Figure 19. 
 

 
Figure 19 - Generate Report: Step 4 of 4 

3.2.3.4 Properties 
Used to edit the project and configure the server and simulation information for the 
current project. There are three panels, one for each set of parameters. Navigation to each 
of the panels is done by clicking on one of the three buttons located on the left column of 
the window. 

3.2.3.4.1 Properties Panel 
Used to modify the project’s properties such as its title, description and topology; this is 
the default panel when selecting the “Project->Properties” menu option. See Figure 20. 
 
NOTE: The “Project Name” represents its folder’s name on the physical medium (i.e., the 
hard drive) and the “Project Title” is displayed along with its “Description” in the 
browser window when it is selected. See Figure 35. 
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Figure 20 - Project Properties: Properties Panel 

 

3.2.3.4.2 Server Panel 
Used to configure the GUI for communication with the server; the network address and 
port number are set here for the server that will run the ISSI Network Simulation program. 
 
IMPORTANT: The Server information must be properly configured in order for the GUI 
to communicate with the server. 
 
Enter the address (IP address or DNS name) and the port number for the server that will 
run the simulations (see Figure 21). The “Check” button may be used to check the 
validity of the server’s address; if the server’s address can be resolved and 
communication with the server can be established then a green check mark will appear 
next to the address; otherwise, a red X will indicate the communication error, see Figure 
22 and Figure 23. 
 
A checkbox is available to indicate whether to delete or not delete the results from the 
server after simulation runs are completed. Simulation results are downloaded to the GUI 
for display and analytical purposes after the server has finished processing them; leaving 
the results/files on the server may be of use for debugging purposes, however by default 
the results/files are deleted from the server. 
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Figure 21 - Project Properties: Server Panel 

 
 

 
Figure 22 - Server’s Address Validated 

 
 

 
Figure 23 - Invalid Server’s Address 

3.2.3.4.3 Simulation Panel 
The “Simulation Time” field is used to configure the amount of time (in seconds) that the 
program should simulate. The minimum value is one (1) second and the maximum value 
is 2,147,483,646 (231-2). See Figure 24. 
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The “Debug” checkboxes are used to indicate whether specific debug information will be 
captured during the simulation run. The debug information is displayed in the 
“FileViewer” window under the “Log File” tab after the simulation run is done. 
 
The “Simulation seed” field is used to set the simulation’s random number generator’s 
seed value. 
 

 
Figure 24 - Project Properties: Simulation Panel 

3.2.4 View Pull-down Menu 
The “View” pull-down menu contains the following options: 

• Display RFG statistics 
• Switch Mode (Ctrl+M) 

3.2.4.1 Display RFG statistics 
This menu option is a toggle for viewing the radio frequency gateway (RFG) statistics. 
By default this option has a checkmark indicating that the RFG statistics are shown. 
 

The RFG statistics matrix  is displayed above the RFG icon; the colored 
numbers represent the following: 
• Number of registered SUs (as home) - green 
• Number of registered SUs (as serving) - blue 
• Number of active SUs in SU-to-SU calls - orange  
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• Number of registered groups (as home) - pink 
• Number of registered groups (as serving) - gray 
• Number of active group calls - light blue 

 
NOTE: Per P25 terminology [1], the “home” is the node that has access to directory 
information of an SU and it keeps track of the current location of the SU. The “serving” 
is the node that has successfully registered an SU. 

3.2.4.2 Switch Mode 
This option allows for switching between design and read-only mode. The design mode 
allows for activities such as creating and modifying the project’s topology and its 
applications. The read-only mode disallows modifications and allows for activities such 
as playing back the simulation (once the simulation run is successfully completed from 
the server), running the project analysis tool (“Project->Project Analysis”), and viewing 
statistics and results via the “Statistics” panel. 

3.2.5 Tools Pull-down Menu 
The “Tools” pull-down menu contains the following option: 

• Audio Trace Generator (Ctrl+G) 
• Trace Viewer (Ctrl+T) 
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3.2.5.1 Audio Trace Generator 
The Audio Trace Generator main window consists of three panels: The “Sound Graph” 
panel, the “Automatic Parsing Configuration” panel and the “Spurt Assignment” panel. 
See Figure 25. 
 

• Sound Graph: Graphical display of the sound stream. 
• Automatic Parsing Configuration: Allows for setting configuration values. 
• Spurt Assignment: Allows for associating or disassociating audio spurts to user(s). 

 

 
Figure 25 - Audio Trace Generator: Initial Panel 
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3.2.5.1.1 File Pull-down Menu 
The “File” pull-down menu contains the following items: 

• New: Opens a window for creating a new audio project (Ctrl+N). See Figure 26. 
 

 
Figure 26 - Audio Trace Generator: New Project Configuration Window 

 
• Open: Opens a browser window to search for an existing audio project (Ctrl+O). 

NOTE: Audio projects are indicated by blue diamonds. See Figure 27. 
 

 
Figure 27 - Audio Trace Generator: Search for Existing Audio Projects 

 
• Close: Closes the current project. 
• Save: Saves the current project. 
• Save As: Saves the current project to another directory, using another name, or 

both. 
• Properties: Opens the current project’s properties window and allows for its 

modification, see Figure 28. 
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Figure 28 - Audio Project Properties Window 

 
• Exit: Exits the tool. 

3.2.5.1.2 Window Pull-down Menu 
This menu option lists all opened audio projects and allows for switching between the 
projects. 

3.2.5.1.3 Help Pull-down Menu 
The “Help” pull-down menu contains the following options: 

• Log Information: Displays a window with status and processing information 
• Help Contents: Displays a window with instructions for using the tool 
• User Documentation: Displays this document 
• About: Displays the software disclaimer, modules, and contact information 

3.2.5.1.4 Audio File Buttons 
Located under the menu are the “Audio File Control” buttons. Click the “Play Audio 
File” button  to play the audio file. Once playback has started, the button will change 
to the stop icon  and it can be used to stop the playback. The zoom buttons  
are used to expand and contract the length of the graph in the “Sound Graph” panel. 

3.2.5.1.5 Automatic Parsing Configuration Panel 
The “Automatic Parsing Configuration” panel contains the “Noise Threshold” parameter, 
the “Minimum Break Length” parameter and the “Parse Audio” button. 
 
Noise Threshold: Enter an appropriate value or accept the fixed increment sizes. This 
value represents the threshold in the signal’s amplitude to determine if the signal is active 
or idle. 
 
Minimum Break length: Enter an appropriate value or accept the fixed increment sizes. 
This value represents the minimum length of idle (silence) that must occur between audio 
activities to determine the separation between the audio spurts. 
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Parse Audio button: Use this button to analyze and separate the audio stream into idle and 
active periods. The results are indicated with red and green vertical lines for the spurts’ 
boundaries. Left click on a spurt will highlight it yellow. Right-click on a spurt to display 
a pop-up menu; the menu options are “Delete Spurt” and “Split Spurt”. See Figure 29. 
 

 
Figure 29 - Audio Spurts 

 
• Delete Spurt: Allows for deleting the selected spurt 
• Split Spurt: Allows for splitting the selected spurt into halves 

 
NOTE: Grab and drag on a spurt’s boundary to resize the spurt 

3.2.5.1.6 Spurt Assignment Panel 
The “Spurt Assignment” panel contains the “Unassigned Spurt(s)” subpanel, the “Users” 
subpanel and various control buttons. 
 
After loading an audio file, set the appropriate values in the “Automatic Parsing 
Configuration” panel then click the “Parse Audio” button to analyze and separate the 
audio stream into idle and active periods. Each spurt will be numbered and its start and 
end time will be indicated. 
 

• Unassigned Spurts(s) subpanel: This subpanel contains all the spurts that were 
created from using the “Parse Audio” button. These spurts can later be assigned to 
appropriate users. 

• Users subpanel: This subpanel contains all users created for spurt assignments. 
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3.2.5.1.6.1 Spurt Assignment Panel Buttons 
Select a spurt from the “Unassigned Spurts(s)” subpanel then use the “Play Selected 
Spurt” button  to play back that spurt. While playing back a spurt, this button will 
change to the stop icon  and can be used to stop the playback of the spurt. Playing 
back spurts is useful for assigning spurts to the appropriate user(s). 
 

• The “Add New User” button  allows for creating new users in the “Users” 
subpanel. 

• The “Remove the Selected User” button  allows for deleting users from the 
“Users” subpanel. 

• The “Rename the Selected User” button  allows for renaming users in the 
“Users” subpanel. 

 
Select a spurt from the “Unassigned Spurts(s)” subpanel and use the “Add Spurt” button 
to associate and move that spurt to the currently selected user in the “Users” subpanel. 
See Figure 30. 
 

 
Figure 30 - Spurt Association with User 

 
Select a spurt from the “Users” subpanel (associated with the selected user) and use the 
“Remove Spurt” button to disassociate that spurt from the selected user and move it to 
the “Unassigned Spurt(s)” subpanel. See Figure 31. 
 

 
Figure 31 - Spurt Disassociation with User 
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3.2.5.2 Trace Viewer 
The Trace Viewer main window consists of five panels: The “Data Selection” panel, the 
“Message Selection” panel, the “Interval Selection” panel, the “Graphical Display” panel 
and the “Status Information” panel. See Figure 32. 
 

• Data Selection: Allows for filtering on applications, subscriber units, groups or all 
data from the trace file. 

• Message Selection: Allows for selecting the types of messages or events to 
display. 

• Interval Selection: Allows for selecting the time interval from the trace file. 
• Graphical Display: Displays the graphical results of the messages and events from 

the trace file. 
• Status Information: Displays status information. 

 

 
Figure 32 - Trace Viewer Main Window 
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3.2.5.2.1 Graphical Display Panel 
The “Graphical Display” panel displays the Radio Frequency Gateways (RFGs) via 
vertical lines with the name of each RFG labeled at the top. The far left vertical line 
represents the time line from the trace file. Messages and events are drawn with their 
source and destination (if applicable) RFGs. Events are indicated by circles and can only 
occur on one RFG; messages may occur on only one RFG (indicated by an arrow head) 
or they may originate from one RFG and end on another RFG. Messages containing 
source and destination RFGs are indicated via lines ending with arrow heads. See Figure 
33. 
 
Note that the “Graphical Display” panel supports scrolling through the trace file and 
displaying the trace information accordingly. 
 

 
Figure 33 - Graphical Display Panel 
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3.2.5.2.2 Data Selection Panel 
At the top of the Trace Viewer main window is the “Data Selection” panel, it allows for 
filtering on Applications, Subscriber Units, Groups or All data from the trace file. 
 
Select the primary filter criteria by clicking on the appropriate radio button - Applications, 
Subscriber Units, Groups or All. For the Applications, Subscriber Units and Groups radio 
buttons, the appropriate combo box will be enabled to allow for selecting the appropriate 
secondary search criteria. See Figure 34. 
 
Note that the “Submit Parameters” button must be selected in order to process all 
parameters (including those from the “Interval Selection” panel) and to display the 
appropriate information in the “Graphical Display” panel. 
 

 
Figure 34 - Data Selection by Subscriber Units 
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3.2.5.2.3 Message Selection Panel 
The “Message Selection” panel allows for selecting the types of messages or events to 
display. 
 
Messages and events are grouped and color coded with default colors. Use the check 
boxes on the left to select the groups of messages and events to be displayed. Use the 
buttons on the right to change the default colors used for drawing the lines of the 
associated groups of messages and events. See Figure 35 and Figure 36 as examples. 
 

 
Figure 35 - Message Selection Panel 

 
 

 
Figure 36 - Window for Changing a Group’s Color 
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To change the individual colors and/or to enable/disable the processing of particular 
messages and/or events, invoke the “ISSI Event and Message Settings” window by 
selecting “Edit->ISSI Event and Message Settings” from the main menu. Use the check 
boxes on the right to select the messages and/or events to process (see Figure 37). Click 
on a particular message/event color to change its color (see Figure 36 as an example of 
the color options window). The “Commit” button must be selected to commit the changes. 
Select the “Reset” button to reset this window to the system’s default settings (see Figure 
37). Figure 33 shows the lines for the Push-To-Talk (PTT) messages in green as indicated 
by the color chosen in the “ISSI Event and Message Settings” window. 
 
If two or more messages or events occupy the same time (i.e., they are co-located) then 
they are drawn in black. Lines that represent multiple messages are labeled with the 
appropriate number of messages in the graphical display panel. See Figure 38. 
 

 
Figure 37 - ISSI Event and Message Settings Window 
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3.2.5.2.4 Selection Details Window 
The “Selection Details” window allows for zooming in to a smaller area from within the 
“Graphical Display” panel of the Trace Viewer main window. Note that the “Selection 
Details” window contains its own graphical display panel that can also be used to zoom 
in further. The “Selection Details” window is displayed by using the mouse to drag and 
draw a rectangle from within the “Graphical Display” panel of the main Trace Viewer 
window; this action outlines the zoom area and invokes the “Selection Details” window. 
See Figure 38. 
 

 
Figure 38 - Selection Details Window Displaying Multiple Events and Messages 

 
The list of events and messages for the zoomed in area is located at the bottom of the 
“Selection Details” window. Double-click on any of the items from this list to bring up 
that item’s detailed information. See Figure 39 and Figure 40 as examples. 
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Black circles, arrow heads (triangles) and lines represent multiple events or multiple 
messages; double-click on them to bring up the appropriate window displaying the events 
or messages contained within. Figure 41 shows the “Messages” window containing co-
located messages. Double-click on a message or an event from this window will bring up 
the appropriate detailed information window (as shown in Figure 39 and Figure 40). 

 

 
Figure 39 - Event Detailed Information Window 

 
From the “Detailed Information” window, the “Node” buttons allow for invoking the 
“Node Information” window (see Figure 42). The “Trace” buttons, if enabled, allow for 
invoking the “Trace Parameter Details” window (see Figure 43). 
 

 
Figure 40 - Message Detailed Information Window 

 

 
Figure 41- Messages Window 
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Figure 42 - Node Information Window 

 
From the “Node Information” window, if that node contains one or more groups or one or 
more subscriber units, then the associated button(s) would be enabled. Click on the 
“Groups” button to invoke the “Groups” window (see Figure 44). Click on the “SUs” 
button to invoke the “Subscriber Units” window (see Figure 45). 
 

 
Figure 43 - Trace Parameter Details Window 
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Figure 44 - Groups Window 

 
From the “Groups” window, double-click on a group to invoke its “Group Information” 
window. See Figure 46. 
 
 

 
Figure 45 - Subscriber Units Window 

 
From the “Subscriber Units” window, double-click on a subscriber unit to invoke its 
“Subscriber Unit Information” window. See Figure 47. 
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Figure 46 - Group Information Window 

 
The “Calls Association” button is enabled if the selected group or if the selected SU is 
associated with at least one call from the trace file. Click on the “Calls Association” 
button to invoke the “Calls Association” window. See Figure 48. 
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Figure 47 - Subscriber Unit Information Window 

 

 
Figure 48 - Calls Association Window 
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From the “Calls Association” window, double-click on the desired call to invoke the 
“Call Information” window (see Figure 49). 
 
From the “Call Information” window, the “Calling SU” and the “Called SU” buttons 
(when available) allow for invoking the “Subscriber Unit Information” window for the 
selected SU (see Figure 47 as an example). 
 

 
Figure 49 - Call Information Window 
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3.2.5.2.5 Interval Selection Panel 
The “Interval Selection” panel allows for selecting the time interval from the trace file to 
process, the option to display the raw trace data in the “Status Information” panel, and the 
option to display message numbers in the “Graphical Display” panel. 
 

 
Figure 50 - Interval Selection Panel 

 
The “Start Time” parameter represents where in the trace file to begin processing 
information. The “Stop Time” parameter represents where in the trace file to end the 
processing. The “Page Size” parameter represents the time frame to use (starting from the 
“Start Time” parameter) for displaying information in the “Graphical Display” panel; e.g. 
with a “Start Time” of 10.000000, a “Stop Time” of 99.784073 and a “Page Size” of 
1.000000, the data that would be displayed in the “Graphical Display” panel is from 
10.000000 seconds to 11.000000 seconds. 
 
The “Show Data” checkbox allows for displaying information such as trace data, 
message and event information in the “Status Information” panel. This is useful for 
looking at raw trace data when needed, or for seeing the messages and/or events selected 
as part of the zoom in process. See Figure 52. 
 
The “Show Message Number” checkbox allows for displaying the message numbers 
corresponding to the messages on display. This is useful if the user prefers to locate 
messages via message numbers instead of message names. See Figure 51. 
 
Note that the “Submit Parameters” button must be selected in order to process all 
parameters (including those from the “Data Selection” panel) and to display the 
appropriate information in the “Graphical Display” panel. 
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Figure 51 - Selection Details Window Showing the Message Number Next to the Message Name 

 

3.2.5.2.6 Status Information Panel 
The “Status Information” panel displays various data from the trace file. See Figure 52. 
 
 

 
Figure 52 - Status Information Panel with the Show Data Checkbox Enabled 

 
 
 



 46 

3.2.6 Windows Pull-down Menu 
The “Windows” pull-down menu contains the following options: 

• Topology (see section 4) 
• Topology Configuration (see section 5) 
• Statistics (see section 6) 
• Media (see section 7) 
• Status (see section 8)  
• FileViewer (see section 9) 
• A list of open projects (see section 10), if any, a green check mark indicates the 

current project 

3.2.7 Help Pull-down Menu 
The “Help” pull-down menu contains the following options: 

• Help Content (Shift+F1): Displays the help pages 
• GUI Documentation (F1): Displays this document 
• Simulation Model Documentation: Displays the simulation model documentation 
• About: Displays the software disclaimer, modules, and contact information 

3.2.7.1 Help Content 
The “Help Content” is a set of help topics displayed via a graphical user interface; it can 
also be invoked using the shortcut key combination Shift+F1. See Figure 53. 
 
Where appropriate, various windows contain the “Help” button that is located at the 
bottom right; pressing on those help buttons give context help specific to their respective 
subject matter. Figure 54 shows the “Help” button for the Authentication Credentials 
Window. 
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Figure 53 - Help Content Window 

 

 
Figure 54 - Authentication Credentials Window Showing the Help Button 

3.3 Icons 

  - Open Project (Ctrl+O) 
Opens a browser window to locate and load simulation projects 
 

 - Launch simulation in the server (Ctrl+R) 
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Authenticates the user to the simulation server (if not already authenticated), uploads the 
current project’s pertinent files to the server, runs the simulation on the server, and 
downloads simulation result files from the server to the GUI for analytical and display 
purposes. 
 
IMPORTANT: The current project and its files containing the latest topology and 
configuration will be saved to the hard drive when any simulation run is done. If the user 
wishes to keep the original configuration of the project, it is recommended that a copy of 
the original project be saved using the “File->Save As…” function before making major 
modifications then running simulations. However, the user may use the “Edit->Undo” 
function to revert back to the project’s original configuration. 
 

 - Simulation running 
Indicates the current project’s simulation was launched in the server and is still running. 
 

 - Simulation not running 
Indicates the current project’s simulation was not launched in the server. 
 

 - Project is currently in design mode (toggles with read-only mode icon) 
Clicking on this icon puts the project into read-only mode (Ctrl+M) 
 

 - Project is currently in read-only mode (toggles with design mode icon) 
Clicking on this icon puts the project into design mode (Ctrl+M) 

3.4 Windows and Panels 
The “Windows” pull-down menu options allow for displaying all available panels that the 
GUI has to offer using a layout consisting of tabs. Selecting a particular panel under the 
“Windows” menu will display that panel in the foreground within the GUI’s 
encapsulating main window. See Figure 57. 
 
Each panel has 3 buttons to the right of its name: Undock, minimize and close. 
Each panel has 4 buttons on the far right side: Undock, minimize, maximize and close. 
 

Undock  – allows the panel to be separated into its own window 
Dock  – returns the panel to be part of the GUI’s main window 
Minimize  – turns the panel into an icon at the bottom of the GUI’s main window 
Maximize  – returns the panel to its full size within the GUI’s main window 
Close  – removes the panel entirely from the GUI’s main window. Note that all closed 
panels can be reopened using the “Windows” pull-down menu options. 
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3.5 New Project Window 
Use menu option “File->New Project…” to create new projects. Use the “New Project” 
window (see Figure 55) to define the project’s name, the project’s directory/location on 
the hard drive, the project’s title, a short description of the project, select the type of 
topology for the project’s layout/background, and to define the image directories for the 
project. 

3.5.1 Properties Panel 
 

 
Figure 55 - New Project Window 

 
Project Name: The name for the project, this will also be used as the directory/folder 

name for the project; alphanumeric characters and any other valid characters 
that are supported by the platform in use (e.g., Windows, Linux, Mac, etc.). 

Project Location: The directory/folder path; the “Browse…” button is used to 
navigate to or to create the parent directory/folder for the project. 

Project Folder: The folder containing the project’s files; this will be automatically 
created based on the previous two entries. 

Project Title: The title used to identify the project. 
 
Optional Parameters (note that these parameters have built-in default values): 

Description: A brief description of the project that will be displayed in the 
“Open Project file” window. 

Topology: Type of background and coordinate system for the project. 
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- generic: No background is used, the width and height for the 
background will be used. 

- map: A background map is used, use the “Select…” button to 
select a map from the set of available background maps. See 
section 3.5.1.1 for more details. 

 
Image directories: Allows for defining additional directories where background image 

files and icon image files are stored. The GUI will search those directories to 
look for image files if they are not found in the default “image” directory. 

3.5.1.1 Selecting a Map for the Project’s Background 
The map “Select…” button, from the Topology section of the “New Project” screen or 
from the “Project Properties” screen is used to select a map from the GUI’s maps 
database. Select the desired map from the drop down list then click on the “OK” button to 
use the selected map for the project’s background (see Figure 56). 
 

 
Figure 56 - Select map Window 

 



 51 

3.5.2 Server and Simulation Panels  
See section 3.2.3.4.2 for details on the “Server” panel. See section 3.2.3.4.3 for details on 
the “Simulation” panel. 

3.5.3 Completion of Project Information 
After entering the new project information, a blank project window will be displayed (see 
Figure 57). If a map was selected as the background, it will be displayed accordingly. The 
network and its topology are created here; configure the parameters by selecting from the 
topology icons located in the “Topology Configuration” panel (on the right) and dropping 
the icons into the “Topology” panel (on the left). 
 

 
Figure 57 - New/Blank Project (Design) Window 

 
NOTE: These panels can be displayed by selecting them from the “Windows” pull-down 
menu options if they are not already visible. 
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3.6 Open Project Window 

Use the “Open Project” icon  or the menu option “File->Open Project…” to bring 
up a browser window for locating existing projects (projects are marked by red 
diamonds). See Figure 58. 
 

 
Figure 58 - Browser Window Showing Simulation Projects 
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4 Topology Panel 
The Topology panel contains four subpanels: The “Topology” subpanel contains a 
graphical representation of the current project’s topology; the “Simulation Progress” 
subpanel displays the time line during playback of the simulation via the master control 
bar; the “Zoom” subpanel controls the size of the “Topology” subpanel; and the “Speed” 
subpanel controls the playback speed for the “Simulation Progress” subpanel. The Play 
(also known as the “action” button) and Stop buttons control the simulation playback 
function. See Figure 59. 
 

 
Figure 59 - Topology Panel 

 

4.1 Topology Subpanel 
For new projects, the “Topology” subpanel is initially blank (or may contain a 
background image depending on the project’s configuration). For active projects, the 
actions available are dependent on their topologies and on user defined activities for 
those projects. The exact actions available depend on the contents of the projects. 
 
To create a network topology, click on the template icons from the “Topology 
Configuration” panel and drop them into the “Topology” subpanel (see Figure 60). Refer 
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to the “Network Primer” appendix for more information about creating a network 
topology. 
 
For a project that uses a map for its background, placing the pointer in the “Topology” 
subpanel will display the (X,Y) coordinates of the pointer with (0,0) being the upper left 
corner of the subpanel and (maximum value of X, maximum value of Y) being the lower 
right corner of the subpanel. The Global Positioning System (GPS) coordinates will be 
displayed in the lower left corner of the subpanel. 

NOTE: The range and maximum values for either of the coordinate systems were 
set when the new project was created (see Figure 55, the “Topology” section of 
the panel). 

 
For a project that does not use a map for its background, placing the pointer in the 
“Topology” subpanel will display the (X,Y) coordinates of the pointer with (0,0) being 
the upper left corner of the subpanel and (maximum value of X, maximum value of Y) 
being the lower right corner of the subpanel. 

NOTE: The maximum values for X and Y were set when the new project was 
created (see Figure 55, the “Topology” section of the panel). 

 
For an active project, the “Topology” subpanel will display the layout of the topology. 
 

 
Figure 60 - Topology Subpanel with an Active Project 

 
ACTIONS: 
• Single clicking on any of the nodes or links will open its entry under the “Topology 

Configuration” panel. 
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• Right-clicking on a node icon in the “Topology” subpanel will display a pop-up menu 
with the following options: Properties, Delete, Hide Icon, Hide Description and Hide 
Range. 
o Select the “Properties” option to display the properties window that can be used to 

modify the associated parameters. 
o Select the “Delete” option to delete the object from the topology. 
o Select the “Hide Icon” option to prevent the icon from showing in the “Topology” 

subpanel. 
o Select the “Hide Description” option to prevent the icon’s description from 

showing in the “Topology” subpanel. 
• Pointing then hovering over any node will display its name. 
• Pointing then hovering over any link will display some of the link’s configuration 

parameters. 
• Pointing then hovering over the statistical icon of any RFG will display some 

statistics for that particular RFG. Also see section 3.2.4.1. 
• Right-clicking in a blank (non-iconic) part of the “Topology” subpanel will display a 

pop-up menu with the following options: Take Snapshot, Save As and Print. 
o Select the “Take Snapshot” option to capture the current view of the “Topology” 

subpanel to be included in the snapshot list of the PDF report (see Section 3.2.3.3). 
o Select the “Save As” option to save the “Topology” subpanel to an image file. 
o Select the “Print” option to print the image of the “Topology” subpanel. 

 
If the “View->View RFG statistics” option is selected from the main menu bar, then an 
icon will be displayed above each node with six numbers in a two rows by three columns 
matrix. The first number (shown in green) represents the number of SUs registered with 
that node as their home RFSS. The second number (shown in blue) represents the number 
of SUs registered with that node as their serving RFSS. The third number (shown in 
orange) represents the number of active SUs in SU-to-SU calls located at that node. The 
fourth number (shown in pink) represents the number of registered groups with that node 
as their home. The fifth number (shown in gray) represents the number of registered 
groups that node serves. The sixth number (shown in light blue) represents the number of 
active group calls at that node. Also see section 3.2.4.1. 
 

4.2 Simulation Progress Subpanel 
This subpanel contains the master control bar that shows the length of the entire 
simulation, as well as the current time position during the playback of the simulation. 
 

4.3 Zoom Subpanel 
This subpanel controls the graphic size of the “Topology” subpanel (i.e., the background). 
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4.4 Speed Subpanel 
This subpanel controls the speed at which the simulation events are played back or 
displayed. 

NOTE: The speed control is not functional for projects containing media file(s). 

4.5 Buttons 
The “action” and “stop” buttons are inactive until a project is loaded and the simulation 
results from the server for that project is available for playback. 

4.5.1 Action Button (Play/Pause/Resume) 
The “Action” button has the following modes: 
• When “Play” is displayed, select this button to begin the playback of the simulation; 

once in playback mode, the button will display “Pause”. 
• When “Pause” is displayed, select this button to pause the playback of the 

simulation; once in pause mode, the button will display “Resume”. 
• When “Resume” is displayed, select this button to resume playback of the 

simulation; once in resume mode, the button will display “Pause”. 

4.5.2 Stop Button 
The “Stop” button is used to stop the playback of the simulation; once the simulation is 
stopped, the “Action” button will display “Play”. 
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5 Topology Configuration Panel 
The Topology Configuration panel contains three subpanels: Templates, Topology Folder 
and Information. 
 

 
Figure 61 - Topology Configuration Panel 

 

5.1 Template Subpanel:  
The template subpanel contains four categories of templates: Nodes, Links, SUs/Groups, 
and Calls and Applications. 

5.1.1 Nodes 
Provided templates are Router and RFG. 

5.1.2 Links 
Supported templates are Duplex link and Simplex link. 

5.1.3 SUs/Groups 
Supported templates are SU and Group. 

5.1.4 Calls and Applications 
Supported templates are SU to SU call, Group call and IP traffic. 
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ACTIONS: 
Each category of template can be expanded or collapsed by clicking on the icon indicated 
below: 
 

 - Expand category 

 - Collapse category 
 
In design mode, right-clicking on a template icon will display a pop-up menu with the 
following options: 

• Edit template 
• Duplicate template 
• Delete template 

5.2 Topology Folder Subpanel  
This subpanel represents the project’s topology in a folder structure and allows the user to 
navigate the topology by expanding and contracting the folders. The root of the folder 
structure is named “Topology”. 
 
The “Topology” folder contains three folders:  

• Nodes (see section 5.2.1) 
• Links (see section 5.2.2)  
• Applications (see section 5.2.3) 

 
ACTIONS: 
• Single clicking on the plus symbol will expand the folder’s structure. 
• Single clicking on the minus symbol will collapse the folder’s structure. 
• Double clicking on the folder icon or the folder name will toggle between expanding 

and collapsing the folder’s structure. 

5.2.1 Nodes 
The “Nodes” folder contains all nodes in the topology. Currently, the node types 
supported are routers or radio frequency gateways (RFG). All nodes have a common set 
of configuration parameters. Depending on the function of the node, additional 
configuration parameters may be available. 
  
ACTIONS: 
• Single click on a node’s name to display a common set of configuration parameters, 

and if applicable additional configuration parameters. 
• In design mode, right-click on a node’s name to display a pop-up menu with five 

options: Properties, Delete, Hide Icon, Hide Description and Hide Range. 
o Select “Properties” to display the node’s properties window for modifying its 

parameters. 
o Select “Delete” to delete the node from the topology. 
o Select/unselect “Hide Icon” to hide/show the icon in the “Topology” panel. 
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o Select/unselect “Hide Description” to hide/show the name of the icon in the 
“Topology” panel. 

o “Hide Range” is grayed out and is currently not applicable. 

5.2.1.1 Routers 
Routers are the basic building blocks upon which P25 networks are built. 
 
ACTIONS: 
• Single click on a router’s name to display the “Router information”. See Figure 62. 
 

 
Figure 62 - Topology: Router Information 

5.2.1.2 RFGs 
Radio Frequency Gateways provide P25 ISSI functionality. The RFG is a router with 
additional ISSI functions enabled. If the RFG has been configured to be “home” for at 
least one SU, then the RFG will have an associated SU folder (see section 5.2.1.2.1). If 
the RFG has been configured to host at least one group, then it will have an associated 
Group folder (see section 5.2.1.2.2). 
 
ACTIONS: 
• Single click on a RFG’s name to display the “Router information” and “P25/ISSI 

information”. See Figure 63. 
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Figure 63 - Topology: RFG Information 

5.2.1.2.1 SUs folder 
Expand the “SUs” folder to show the individual subscriber units (if any). 
  
ACTIONS: 
• Single click on an SU name to display the “SU configuration”, “Service Profile”, 

“Mobility information” and “Calls” information. See Figure 64. 
• Right-click on an SU name to display a pop-up menu with two options: Properties 

and Delete. 
o Select “Properties” to display the SU’s properties window for modifying its 

parameters. 
o Select “Delete” to delete the SU from the topology. 
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Figure 64 - Topology: SU Information 

5.2.1.2.2 Groups folder 
Expand the “Groups” folder to show the individual groups (if any). 
 
ACTIONS: 
• Single click on a group’s name to display the “Group configuration”, “Service 

Profile”, “SUs” (if any SUs are configured) and “Calls” information. See Figure 65. 
• Right-click on a group’s name to display a pop-up menu with two options: Properties 

and Delete. 
o Select “Properties” to display the group’s properties window for modifying its 

parameters. 
o Select “Delete” to delete the group from the topology. 
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Figure 65 - Topology: Group Information 

 
Double click on the group’s name or expand its folder to list the SUs that are configured 
for that group. Single click on an SU’s name listed under that group to display that SU’s 
information (the SU’s information would be similar to that shown in Figure 64). If a 
group name cannot be expanded, then it means that group was defined but has no SUs 
assigned to it. 

5.2.2 Links 
The “Links” folder contains all links in the topology. Link names are presented as pairs 
of nodes (end points). 
 
ACTIONS: 
• Single click on a link’s name to display the “Link information”. See Figure 66. 
• Right-click on a link’s name to display a pop-up menu with two options: Properties 

and Delete. 
o Select “Properties” to display the link’s properties window for modifying its 

parameters. 
o Select “Delete” to delete the link from the topology. 
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Figure 66 - Topology: Link Information 

5.2.3 Applications  
The “Applications” folder contains all applications in the topology sorted by their start 
time. Supported applications are: CBR Traffic, Exponential Traffic, FTP Traffic, Group 
Call, Bulk Group Call, SU-to-SU Call and Bulk SU Call. 
 
ACTIONS: 
• Right-click on an application’s name to display a pop-up menu with two options: 

Properties and Delete. 
o Select “Properties” to display the application’s configuration window for 

modifying its parameters. 
o Select “Delete” to delete the application. 

• Single click on a CBR, an Exponential or an FTP application name to display the 
“Traffic configuration”, “(Application) configuration”, “UDP agent configuration” (if 
UDP is used) or “TCP agent configuration” and “TCP sink agent configuration” (if 
TCP is used). See Figure 67, Figure 68 and Figure 69 as examples for the various 
parameters of the traffic applications. 
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Figure 67 - Topology: CBR Application Information 

 

 
Figure 68 - Topology: Exponential Application Information 
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Figure 69 - Topology: FTP Application Information 

 
• Single click on a group call name to display the “Group call configuration”. See 

Figure 70. 
 

 
Figure 70 - Topology: Group Call Application Information 

 
• Single click on a bulk group call name to display the “Bulk group call configuration”. 

See Figure 71. 
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Figure 71 - Topology: Bulk Group Call Application Information 

 
• Single click on an SU-to-SU call name to display the “Unit to Unit call configuration”. 

See Figure 72. 
 

 
Figure 72 - SU-to-SU Call Application Information 
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• Single click on a bulk SU call name to display the “Bulk Unit to Unit call 
configuration”. See Figure 73. 

 

 
Figure 73 - Bulk SU Call Application Information 
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6 Statistics Panel 
The Statistics panel contains two subpanels: Statistics Folder and Graph/Information. See 
Figure 74. Note that statistics are only available for applications and actions that 
generated traffic in the network. 
 

 
Figure 74 - Statistics Panel 

 
The root “Statistics” folder contains performance statistics from the simulation server’s 
results. The layout allows the user to navigate by expanding and collapsing the folders. 
 
The statistics folder contains four folders: 

• P25/ISSI 
• Traffic flows 
• Nodes 
• Links 

 
ACTIONS: 
• Single click on the Plus symbol to expand the folder. 
• Single click on the Minus symbol to collapse the folder. 
• Double click on the folder’s icon or the folder’s name to toggle between expanding 

and collapsing the structure under that folder. 
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NOTE: All graphs show statistics up to the time indicated by the master control bar in the 
“Simulation Progress” subpanel. If the master control bar is at the beginning of the 
simulation, it is possible that the graphs will be empty since there are no activities yet. 
 

6.1 P25/ISSI Folder 
The “P25/ISSI” folder contains statistics specifically related to “Project 25: Inter-RF 
Subsystem Interface (ISSI)”. The five folders under the P25/ISSI folder are RFSS, SUs, 
Groups, SU-to-SU Calls and Group Calls. If a folder has additional folders under it then 
it will have a folder icon next to its name. If a folder has no additional folders under it 
then it will be shown with just its name. 

6.1.1 RFSS Folder 
The “RFSS” folder contains individual RFSS nodes as folders. 
 
ACTIONS: 
• Single click on the individual RFSS name to display information related to its SU and 

group activities. 
o The SU activity table contains the following items and their values:  
 SU registrations initiated by this node 
 SU registrations completed by this node 
 SU registrations received by this node 
 SU registrations accepted by this node 
 SU-to-SU calls initiated 
 SU-to-SU calls completed 

o The group activity table contains the following items and their values:  
 Group registrations initiated by this node 
 Group registrations completed by this node 
 Group registrations received by this node 
 Group registrations accepted by this node 
 Group calls initiated 
 Group calls completed 

• Double click on the individual RFSS name to expand and reveal its “instant” folder. 

6.1.1.1 Instant folder 
ACTIONS: 
• Double click on the “instant” folder to expand and reveal the following items: 

o Number of SUs currently registered as home 
o Number of SUs currently registered as serving 
o Number of SUs with active calls 
o Number of groups currently registered as home 
o Number of groups currently registered as serving 
o Number of groups with active calls 

 
• Single click on any of these items will display a graph of its statistic. 
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• Pointing then hovering over any of the graph’s data point will display its values (see 
Figure 75). 

 

 
Figure 75 - Statistics: RFSS Graph 

6.1.2 SUs folder 
The “SUs” folder contains individual subscriber units (SU) as folders. 
 
ACTIONS: 
• Single click on an SU name to display information (servings and calls) about the SU’s 

activities from the simulation. See Figure 76. 
 

 
Figure 76 - Statistics: SU 

 
• The servings table contains the following information: 

o Start Time: Time the request (action) was initiated 
o Processed Time: Time the “home” received the request 
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o Confirmed Time: Time the response was received by the “serving” 
o Completion Delay: Time it took to complete the request (start to finish) 
o RFG: Node that initiated the request 
o Action: Type of request (Registration or Deregistration) 
o Status: The status of the request (Success or Failure) 

 
• The calls table contains the following information: 

o Name: The name used to identify this call (application) 
o Start Time: Time the call was initiated 
o Stop Time: Time the call ended 
o Call type: SU-to-SU or Group 
o Peer: Indicates the peer that this SU is communicating with for SU-to-SU calls. 

Indicates the group name that is involved for group calls. 
o Calling/Called: Indicates the role for this SU in the call. 

6.1.3 Groups Folder 
The “Groups” folder contains individual groups as folders if any are defined. 

6.1.3.1 Individual Group Folder 
ACTIONS: 
• Single click on a group name to display the serving RFSSs for the group and any 

related group calls statistics. See Figure 77. 
 

 
Figure 77 - Statistics: Group 

 
• Double click on a group name to show the “Number of servings currently registered” 

item. 
• Single click on the “Number of servings currently registered” item to show the graph 

for its statistics. 
• Pointing then hovering over any of the graph’s data point will display its values. 

6.1.4 SU-to-SU Calls Folder 
The “SU-to-SU Calls” folder contains SU-to-SU calls and bulk SU calls as folders (if 
any) as well as the “All” folder that summarizes all calls in the project. Bulk SU calls are 
calls containing multiple SU-to-SU calls under the “bulk”; they are used to simplify the 
generation of multiple SU-to-SU calls. See Figure 78. 
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Figure 78 - Statistics: Expansion of the SU-to-SU Calls Folder 

 
NOTE: All failed calls do not have a folder icon next to their names hence they are not 
expandable. 
 
ACTIONS: 
• Single click on a failed call name to show its “Call information” which contains the 

“Status” field with the error message. See Figure 79 and Figure 80. 
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Figure 79 - Statistics: SU-to-SU Call Failure under a Bulk SU Call 

 

 
Figure 80 - SU-to-SU Call Failure 

6.1.4.1 Bulk SU Call Folder 
ACTIONS: 
• Double click on an individual bulk SU call name to display all of the SU-to-SU calls 

in that bulk. All successful SU-to-SU calls in that bulk will have a folder icon next to 
their names while all unsuccessful calls will not have the folder icon next to their 
names and therefore cannot be expanded. See Figure 81. 
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Figure 81 - Statistics: Bulk SU Call Members 

 
• Single click on any successful SU-to-SU call in the bulk to display its “Call 

information” and “Statistics snapshot”. In this example, the SU-to-SU call 
“BulkSUcall0_1” was the only successful call in the bulk SU call “BulkSUcall0” 
shown in Figure 81. The following section gives more details about the “SU-to-SU 
Call Folder”. 

6.1.4.2 Individual SU-to-SU Call Folder 
ACTIONS: 
• Single click on an individual SU-to-SU call to display its “Call Information” and a 

“Statistics snapshot”, see Figure 78. 
 

o The “Call Information” consists of: 
 Calling: This identifies the SU initiating the call. 
 Called: This identifies the SU receiving the call. 
 Initial Transmission: This indicates which SU began the voice transmission. 
 Preference: This indicates whether availability check was requested or not. 
 Duplex: This indicates whether the communication was half or full duplex. 
 Start time: This indicates the time when this call was initiated. 
 Setup Delay: This indicates the time that it took to establish the call from end 

to end. 
 Stop time: This indicates the time when this call was stopped. 
 Status: This indicates “Success” if the call succeeded; it indicates “Failure” if 

the call failed to complete. 
 
The “Statistics snapshot” consists of packets sent, packets received, packet delay, packet 
jitter, sending rate and receiving rate. 
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• Double click on an individual call folder to expand and reveal the segment(s) that 
compose the call, as well as the “End-to-End” folder. A segment is the 
communication path between two RFGs. 

6.1.4.2.1 End-to-End Folder 
The “End-to-End” folder contains instant and cumulative statistical information. 
 
ACTIONS: 
• Double click on the “End-to-End” folder to expand and reveal its “Instant” and 

“Cumulative” folders. See Figure 82. 

6.1.4.2.1.1 Instant Folder 
ACTIONS: 
• Double click on the “Instant” folder to expand and reveal the following items: 

Packets sent, packets received, delay, jitter, sending rate and receiving rate. See 
Figure 82. 

• Single click on the individual item to display a graph of its statistic (if values are 
available). See Figure 82. 

• Pointing then hovering over any of the graph’s data point will display its values. See 
the graph in Figure 82. 

 

 
Figure 82 - Statistics: SU-to-SU Call, Packets Sent Graph 
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6.1.4.2.1.2 Cumulative Folder 
ACTIONS: 
• Double click on the “Cumulative” folder to expand and reveal the following items: 

Packets sent, packets received, delay, jitter, sending rate and receiving rate. See 
Figure 82. 

• Single click on the individual item to display a graph of its statistic (if values are 
available). See Figure 82. 

• Pointing then hovering over any of the graph’s data point will display its values. See 
the graph in Figure 82. 

6.1.4.2.2 Segment folder 
The “Segment” folder contains the segments along the transmission path of the call. The 
number of segments for the call is based on the number of communication paths between 
two RFGs of the topology (e.g., calling serving to calling home; calling home to called 
home; called home to called serving). 
 
ACTIONS: 
• Single click on a segment name to display its “Call segment information” and its 

“Statistics snapshot”, see Figure 83. 
 

 
Figure 83 - Statistics: SU-to-SU Call Segment Information 

 
o The “Call segment information” consists of: 
 Start time: This indicates the start time for this segment. 
 End time: This indicates the end time for this segment. 
 End point: The “End point” shows the serving’s name (one per end point). 
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The “Statistics snapshot” consists of packets sent, packets received, packet delay, packet 
jitter, sending rate and receiving rate. 
 
• Double click on an individual segment folder to expand and reveal its “Instant” and 

“Cumulative” folders. 

6.1.4.2.2.1 Instant Folder 
ACTIONS: 
• Double click on the “Instant” folder to expand and reveal the following items: 

Packets sent, packets received, delay, jitter, sending rate and receiving rate. 
• Single click on the individual item to display a graph of its statistic (if values are 

available). 
• Pointing then hovering over any of the graph’s data point will display its values. 

6.1.4.2.2.2 Cumulative Folder 
ACTIONS: 
• Double click on the “Cumulative” folder to expand and reveal the following items: 

Packets sent, packets received, delay, jitter, sending rate and receiving rate. 
• Single click on the individual item to display a graph of its statistic (if values are 

available). 
• Pointing then hovering over any of the graph’s data point will display its values. 

6.1.4.2.2.3 Directional Segment Folder 
ACTIONS:  
• Single click on a directional segment folder to display its “Statistics snapshot” 

consisting of packets sent, packets received, packets dropped, queuing delay, transmit 
delay, sending rate and receiving rate. See Figure 84. 
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Figure 84 - Statistics: SU-to-SU Call Directional Segment Information 

 
• Double click on a directional segment folder to expand and reveal its “Instant” and 

“Cumulative” folders. 

6.1.4.2.2.3.1 Instant Folder 
ACTIONS: 
• Double click on the “Instant” folder to expand and reveal the following items: 

Packets sent, packets received, packets dropped, queuing delay, transmit delay, 
sending rate and receiving rate. 

• Single click on the individual item to display a graph of its statistic (if values are 
available). 

• Pointing then hovering over any of the graph’s data point will display its values. 

6.1.4.2.2.3.2 Cumulative Folder 
ACTIONS: 
• Double click on the “Cumulative” folder to expand and reveal the following items: 

Packets sent, packets received, packets dropped, queuing delay, transmit delay, 
sending rate and receiving rate. 

• Single click on the individual item to display a graph of its statistic (if values are 
available). 

• Pointing then hovering over any of the graph’s data point will display its values. 

6.1.4.3 All Folder 
The “All” folder contains the “End-to-End” folder. This folder represents the 
summarization of the statistics for all calls. See Figure 85. 
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Figure 85 - Statistics: SU-to-SU Calls “All” Summarization Graph Example 

6.1.4.3.1 End-to-End Folder 
The “End-to-End” folder contains the “Instant” and “Cumulative” statistical folders. 
 
ACTIONS: 
• Double click on the End-to-End folder to expand and reveal the “Instant” and 

“Cumulative” folders. See Figure 85. 

6.1.4.3.1.1 Instant Folder 
ACTIONS: 
• Double click on the “Instant” folder to expand and reveal the following items: 

Packets sent, packets received, delay, jitter, sending rate and receiving rate. 
• Single click on the individual item to display a graph of its statistic (if values are 

available). 
• Pointing then hovering over any of the graph’s data point will display its values. 

6.1.4.3.1.2 Cumulative Folder 
ACTIONS: 
• Double click on the “Cumulative” folder to expand and reveal the following items: 

Packets sent, packets received, delay, jitter, sending rate and receiving rate. 
• Single click on the individual item to display a graph of its statistic (if values are 

available). 
• Pointing then hovering over any of the graph’s data point will display its values. 
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6.1.5 Group Calls Folder 
The “Group Calls” folder contains group calls and bulk group calls as folders (if any) for 
the simulation project. Bulk group calls are calls containing multiple group calls under 
the “bulk”; they are used to simplify the generation of multiple group calls. See Figure 86. 
 

 
Figure 86 - Statistics: Expansion of the Group Calls Folder 

 
NOTE: All failed calls do not have a folder icon next to their names hence they are not 
expandable. Non-collocated successful calls that have a folder icon next to their names 
can be expanded to show their segment information if applicable (see “SU1_Groupcall” 
in Figure 86). 
 
ACTIONS: 
• Single click on a call name to show its “Call setup information” and “Lists of 

servings during the call”. The “Status” field in the “Call setup information” shows if 
the call was successful or not. See Figure 87 and Figure 88. 
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Figure 87 - Statistics: Successful Group Call Information 

 

 
Figure 88 - Statistics: Failed Group Call Information 

 
• Double click on an individual group call name to display its segments if applicable. A 

group call will only have a folder icon next to its name if it contains one or more 
segment. See Figure 87. 

6.1.5.1 Segment Folder 
The “Segment” folder contains the segments along the transmission path of the group call. 
The number of segments for the call is based on the number of communication paths 
between two RFGs of the topology. 
 
ACTIONS: 
• Single click on a segment name to display its “Call segment information” and its 

“Statistics snapshot”, see Figure 89. 
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Figure 89 - Statistics: Group Call Segment Information 

 
o The “Call segment information” consists of: 
 Start time: This indicates the start time for this segment. 
 End time: This indicates the end time for this segment. 
 End point: The “End point” shows the serving’s name (one per end point). 

 
The “Statistics snapshot” consists of packets sent, packets received, packet delay, packet 
jitter, sending rate and receiving rate. 
 
• Double click on an individual segment folder to expand and reveal its “Instant” and 

“Cumulative” folders. 

6.1.5.1.1 Instant Folder 
ACTIONS: 
• Double click on the “Instant” folder to expand and reveal the following items: 

Packets sent, packets received, delay, jitter, sending rate and receiving rate. 
• Single click on the individual item to display a graph of its statistic (if values are 

available). 
• Pointing then hovering over any of the graph’s data point will display its values. 

6.1.5.1.2 Cumulative Folder 
ACTIONS: 
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• Double click on the “Cumulative” folder to expand and reveal the following items: 
Packets sent, packets received, delay, jitter, sending rate and receiving rate. 

• Single click on the individual item to display a graph of its statistic (if values are 
available). 

• Pointing then hovering over any of the graph’s data point will display its values. 

6.1.5.1.3 Directional Segment Folder 
ACTIONS:  
• Single click on a directional segment folder to display its “Statistics snapshot” 

consisting of packets sent, packets received, packets dropped, queuing delay, transmit 
delay, sending rate and receiving rate. See Figure 90. 

 

 
Figure 90 - Statistics: Group Call Directional Segment Information 

 
• Double click on a directional segment folder to expand and reveal its “Instant” and 

“Cumulative” folders. See Figure 90. 

6.1.5.1.3.1 Instant Folder 
ACTIONS: 
• Double click on the “Instant” folder to expand and reveal the following items: 

Packets sent, packets received, packets dropped, queuing delay, transmit delay, 
sending rate and receiving rate. 

• Single click on the individual item to display a graph of its statistic (if values are 
available). 
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• Pointing then hovering over any of the graph’s data point will display its values. 

6.1.5.1.3.2 Cumulative Folder 
ACTIONS: 
• Double click on the “Cumulative” folder to expand and reveal the following items: 

Packets sent, packets received, packets dropped, queuing delay, transmit delay, 
sending rate and receiving rate. 

• Single click on the individual item to display a graph of its statistic (if values are 
available). 

• Pointing then hovering over any of the graph’s data point will display its values. 

6.2 Traffic Flows Folder 
The “Traffic Flows” folder contains individual flow’s statistics by its names (if any) and 
the “All” folder. Folders can be expanded to show additional information. 
 

 
Figure 91 - Statistics: Expansion of the Traffic Flows Folder 

 
ACTIONS: 
• Single click on a traffic flow folder name to show its “Flow information” and its 

“Statistics snapshot”, see Figure 91. 
 
o The “Flow information” consists of: 
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 Start Time (s): This indicates the start time(s) for this flow. 
 End Time (s): This indicates the end time(s) for this flow. 
 End Point: The “End Point” shows the serving’s name (one per end point). 

 
The “Statistics snapshot” consists of packets sent, packets received, packet delay, packet 
jitter, sending rate and receiving rate. 
 
• Double click on an individual flow folder to expand and reveal its “Instant” and 

“Cumulative” folders. See Figure 91. 

6.2.1 Instant Folder 
ACTIONS: 
• Double click on the “Instant” folder to expand and reveal the following items: 

Packets sent, packets received, delay, jitter, sending rate and receiving rate. 
• Single click on the individual item to display a graph of its statistic (if values are 

available). 
• Pointing then hovering over any of the graph’s data point will display its values. 

6.2.2 Cumulative Folder 
ACTIONS: 
• Double click on the “Cumulative” folder to expand and reveal the following items: 

Packets sent, packets received, delay, jitter, sending rate and receiving rate. 
• Single click on the individual item to display a graph of its statistic (if values are 

available). 
• Pointing then hovering over any of the graph’s data point will display its values. 

6.2.3 All Folder 
The “All” folder represents the summarization of the statistics for all flows and segments. 
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Figure 92 - Statistics: Traffic Flows “All” Summarization Graph Example 

 
ACTIONS: 
• Double click on the “All” folder to expand and reveal the “Instant” and “Cumulative” 

folders. See Figure 92. 

6.2.3.1 Instant Folder 
ACTIONS: 
• Double click on the “Instant” folder to expand and reveal the following items: 

Packets sent, packets received, delay, jitter, sending rate and receiving rate. 
• Single click on the individual item to display a graph of its statistic (if values are 

available). 
• Pointing then hovering over any of the graph’s data point will display its values. 

6.2.3.2 Cumulative Folder 
ACTIONS: 
• Double click on the “Cumulative” folder to expand and reveal the following items: 

Packets sent, packets received, delay, jitter, sending rate and receiving rate. 
• Single click on the individual item to display a graph of its statistic (if values are 

available). 
• Pointing then hovering over any of the graph’s data point will display its values. 
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6.3 Nodes Folder 
The “Node” folder contains node names as folders; each folder contains statistical 
information about that node. 
 

 
Figure 93 - Statistics: Expansion of the Nodes Folder 

 
ACTIONS: 
• Single click on a node folder name to show its “Statistics snapshot”, see Figure 93. 
 
The “Statistics snapshot” consists of packets sent, packets received, packets dropped, 
packets forwarded, packet delay, sending rate and receiving rate. 
 
• Double click on an individual flow folder to expand and reveal its “Instant” and 

“Cumulative” folders. 

6.3.1 Instant Folder 
ACTIONS: 
• Double click on the “Instant” folder to expand and reveal the following items: 

Packets sent, packets received, packets dropped, packets forwarded, packet delay, 
sending rate and receiving rate. 

• Single click on the individual item to display a graph of its statistic (if values are 
available). 

• Pointing then hovering over any of the graph’s data point will display its values. 
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6.3.2 Cumulative Folder 
ACTIONS: 
• Double click on the “Cumulative” folder to expand and reveal the following items: 

Packets sent, packets received, packets dropped, packets forwarded, packet delay, 
sending rate and receiving rate. 

• Single click on the individual item to display a graph of its statistic (if values are 
available). 

• Pointing then hovering over any of the graph’s data point will display its values. 

6.4 Links Folder 
The “Links” folder contains folders representing unidirectional links between two nodes; 
each folder contains statistical information about that link. 
 

 
Figure 94 - Statistics: Expansion of the Links Folder 

6.4.1 Unidirectional Link Folder 
ACTIONS: 
• Single click on a unidirectional link folder name to show its “Statistics snapshot”, see 

Figure 94. 
 
The “Statistics snapshot” consists of packets sent, packets received, packets dropped, 
queuing delay, transmit delay, sending rate, receiving rate and offered load. 
 
• Double click on an individual unidirectional link folder to expand and reveal its 

“Instant” and “Cumulative” folders. 
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6.4.1.1 Instant Folder 
ACTIONS: 
• Double click on the “Instant” folder to expand and reveal the following items: 

Packets sent, packets received, packets dropped, queuing delay, transmit delay, 
sending rate, receiving rate and offered load. 

• Single click on the individual item to display a graph of its statistic (if values are 
available). 

• Pointing then hovering over any of the graph’s data point will display its values. 

6.4.1.2 Cumulative Folder 
ACTIONS: 
• Double click on the “Cumulative” folder to expand and reveal the following items: 

Packets sent, packets received, packets dropped, queuing delay, transmit delay, 
sending rate, receiving rate and offered load. 

• Single click on the individual item to display a graph of its statistic (if values are 
available). 

• Pointing then hovering over any of the graph’s data point will display its values. 
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7 Media Window 
The “Media” window contains a “Call List” a “User List”, a “Confirm Selection” button 
and a “Status/Information” subpanel. See Figure 95. 
 

 
Figure 95 - Media Window 

 
• Call List: Contains names of call applications that use audio trace files. 
• User List: Lists SUs (users) involved in the selected call applications that are 

associated with audio trace files. 
• Confirm Selection button: Used to confirm the “Call List” and “User List” selection. 
• Status/Information subpanel: Used to relay information to the user. 
 
ACTIONS: 
• Click on a name in the Call List to display the associated users in the User List. 
• Click on a user in the User List to associate the user with the call. 
• Click on the “Confirm Selection” button to confirm the selection of the call and its 

associated user. The call and user selected will be highlighted in green; the associated 
audio trace file will be played during the appropriate time line of the simulation. 
Figure 96 shows the Media window undocked and playing a media file. 

 
NOTE: If an audio file cannot be found, a pop-up window with the appropriate error 
message will be presented. 
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Figure 96- Media Window: Playing Media File 
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8 Status Window 
The “Status” window displays operational messages. 
 

 
Figure 97 - Status Window 

 
ACTIONS: 
• Use the “Font” drop-down list to select the desired font type; use the “Smaller” and 

“Larger” buttons to adjust the font size used in the “Status” area. See Figure 97. 
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9 FileViewer Window 
The “FileViewer” window contains three tabs: Project File, Scenario File, and Log File. 
Each tab displays information for viewing purposes only. See Figure 98. 
 

 
Figure 98 - FileViewer Window 

 
• Project File: Displays the content of the project’s xml file. 
• Scenario File: Displays the content of the project’s tcl file; the tcl file contains the 

“tools command language” (TCL) describing the project’s configuration and topology. 
• Log File: The log file contains the output from the simulation run. 
 
ACTIONS: 
• Select the desired tab to display the content of its associated file. 
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10 List of Opened Projects 
The bottom of the “Windows” menu item contains the list of opened projects once one or 
more projects are loaded. This list allows for swapping between those opened projects; 
the active project is indicated by a green check mark. Selecting a project from this list 
makes that project the active project and loads its information accordingly. See Figure 99. 

 

 
Figure 99 - List of Opened Projects 
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11 Running a Simulation 
To run the simulation for the active project, select the “Launch simulation in the server” 

 button (Ctrl+R). If authentication with the server has not been performed, the 
“Authentication Credentials” window is displayed. See Figure 100. 
 

 
Figure 100 - Authentication Credentials Window 

 
Enter the appropriate user identification and password then select the “OK” button; the 
“Simulation Progress” window is displayed. The length of time that the Simulation 
Progress window is displayed depends on the time it takes the server to process the 
project’s information. Select the “Cancel Simulation” button to cancel the simulation run 
while it is still in progress on the server. See Figure 101. 
 

 
Figure 101 - Simulation Progress Window 

 
Once the simulation run is successfully completed and the Simulation Progress window 
disappears, the “Statistics” panel may be used to display the results. 
 
In the event that the simulation run did not complete successfully, use the “FileViewer” 
window and select the “Log File” tab to display diagnostic information. 
 
NOTE: The diagnostic information is helpful for solving various simulation problems 
such as the problem described above. It can also be helpful with other problems such as 
premature closing of the project while the simulation with the server is incomplete. 
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12 Statistics Computation Methods 
This section describes the methods used to compute the statistics. 

12.1 RFSS Statistics 
Statistic Description 
Overview for SU-to-SU SU Reg initiated 

(serving) 
Number of SU registrations 
initiated as serving during the 
whole simulation 

SU Reg completed 
(serving) 

Number of SU registrations 
successfully completed as serving 
during the whole simulation 

SU Reg received (home) Number of SU registrations 
received as home during the 
whole simulation 

SU Reg accepted (home) Number of SU registrations 
accepted as home during the 
whole simulation 

SU-to-SU calls initiated Number of SU calls initiated 
during the simulation 

SU-to-SU calls 
completed 

Number of SU calls successfully 
setup during the simulation 

Overview for Group Group Reg initiated 
(serving) 

Number of group registrations 
initiated as serving during the 
whole simulation 

Group Reg completed 
(serving) 

Number of group registrations 
successfully completed as serving 
during the whole simulation 

Group Reg received 
(home) 

Number of group registrations 
received as home during the 
whole simulation 

Group Reg accepted 
(home) 

Number of group registrations 
accepted as home during the 
whole simulation 

Group calls initiated Number of group calls initiated 
during the simulation 

Group calls completed Number of group calls 
successfully setup during the 
simulation 

Instant 
These statistics represent 
the value for a given 
window of time during 
the simulation. The 
default interval time 

Number of SUs currently 
registered as home 

Number of SUs registered to this  
RFSS as home at a given point in 
time 

Number of SUs currently 
registered as serving 

Number of SUs registered to this 
RFSS as serving at a given point 
in time 
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Statistic Description 
between two 
measurements is 1 
second. 

Number of SUs with 
active calls 

Number of SUs participating to 
an SU call at a given point in time 

Number of groups 
currently registered as 
home 

Number of groups registered to 
this  RFSS as home at a given 
point in time 

Number of groups 
currently registered as 
serving 

Number of groups registered to 
this RFSS as serving at a given 
point in time 

Number of groups with 
active calls 

Number of groups participating in 
an active group call at a given 
point in time 

12.2 SU Statistics 
Statistic Description 
Serving information Start Time (s) Time the serving RFG sent the first SIP 

Registration message 
Processed Time 
(s) 

Time the home RFG received the 
registration request from the serving RFG 

Confirmed Time 
(s) 

Time the serving RFG received the 
response from the home RFG. 

Completion 
Delay (s) 

Time elapsed between the Start time and 
Confirmed time 

RFG The name of the serving RFG 
Action Indicates if it is a registration/deregistration 
Status The status of the operation (success/fail) 

Call information Name The name of the call 
Start Time (s) Time the first INVITE message was sent to 

setup the call 
Stop Time (s) Time the call ended (N/A indicates the call 

was still active at the end of the simulation) 
Call type Type of call (Group or SU-to-SU call) 
Peer Name of the Peer SU or Group 
Calling/Called Indicates the role of this SU in the call 

(N/A is displayed for Group call) 
Instant 
These statistics 
represent the value for 
a given window of 
time during the 
simulation. The 
default interval time 
between two 
measurements is 1 
second. 

Packets Sent Number of packets sent by this SU 
Packets Received Number of packets received by this SU 
Packets Dropped Number of packets dropped by this SU 
Sending Rate  Transmission rate in bytes/s 
Receiving Rate Receiving rate in bytes/s 



 98 

12.3 Group Statistics 
Statistic Description 
Serving  Start Time (s) Time the serving RFG sent the first SIP 

Registration message 
Setup Delay (s) Time needed to receive the  confirmation 

message 
RFG The name of the serving RFG 
Action Indicates if it is a registration/deregistration 
Status The status of the operation (success/fail) 

Call Start Time (s) Time the first INVITE message was sent to 
setup the call 

Setup Delay (s) Time required to setup the call 
Stop Time (s) Time the call ended (N/A indicates the call 

was still active at the end of the simulation) 
Calling RFG The RFG that initiated the call 
Type Confirmed/Not confirmed 
Status The status of the operation (success/fail) 

Instant 
These statistics represent 
the value for a given 
window of time during 
the simulation. The 
default interval time 
between two 
measurements is 1 
second. 

Number of 
servings 
currently 
registered 

Number of servings registered for this 
group at a given point in time 
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12.4 SU-to-SU Call Statistics 
Statistic Description 
Call information Calling The name of the calling SU 

Called The name of the called SU 
Init. Tx Indicates which SU has the right to 

transmit first 
Preference Indicates if the availability check needs to 

be performed by the called serving 
Duplex Indicates if the call Half/Full duplex 
Start time (s) Time the first INVITE message was sent to 

setup the call 
Setup delay (s) Time required to setup the call 
Stop time (s) Time the call ended (N/A indicates the call 

was still active at the end of the simulation) 
Status The status of the operation (success/fail) 

Statistics snapshot Minimal/Average/Maximum values of the statistics collected 
for this call (See 12.8) 

End-to-End Provides instant and cumulative statistics for the 
communication between the two SUs (see 12.8) 

Segment Provide instant and cumulative statistics for the communication 
between two RFSSs that were part of the call (for example 
between a serving and a home or between two homes). This is 
defined as a call segment. 

Link  Provide instant and cumulative statistics for the communication 
between two nodes that composed the call segment.  

 



 100 

 

12.5 Group Call Statistics 
Statistic Description 
Call Group The group associated with this call 

Calling The RFG that initiated the call 
Type Call type (Confirmed/Unconfirmed) 
Start Time (s) Time the first INVITE message was sent to 

setup the call 
Setup Delay (s) Time required to setup the call 
Stop Time (s) Time the call ended (N/A indicates the call 

was still active at the end of the simulation) 
Status The status of the operation (success/fail) 

Serving RFSS The serving RFSS that joined the group 
call or modify the call segment 

Start Time (s) Time the RFSS joined the group call 
Setup Delay (s) Time required to join the group call  
Stop Time (s) Time the RFSS left the group call 
RTP state State of the RTP resources during the call 

setup 
RF state State of the RF resources during the call 

setup 
Status The status of the operation (success/fail) 

Segment Provide instant and cumulative statistics for the communication 
between the group home RFSS and a serving RFSS that is part 
of the call. 

Link  Provide instant and cumulative statistics for the communication 
between two nodes that composed the call segment.  
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12.6 Node Statistics 
Statistic Description 
Snapshot Minimal/Average/Maximum values of the statistics collected 

as defined in this table. 
Instant 
These statistics represent 
the value for a given 
window of time during 
the simulation. The 
default interval time 
between two 
measurements is 1 
second. 

Packets Sent Number of packets sent from any of the 
node’s interfaces 

Packets Received Number of packets received from any of 
node’s interfaces 

Packets Dropped Number of packets dropped by this node 
Packets 
Forwarded 

Number of packets forwarded by this 
node when acting as a router. 

Packet Delay Delay between the time a packet is 
received and the time it is forwarded. 

Sending Rate  Transmission rate in bytes/s 
Receiving Rate Receiving rate in bytes/s 

Cumulative 
These statistics represent 
the measurement 
collected from the 
beginning of the 
simulation. 

Packets Sent Number of packets sent from any of the 
node’s interfaces 

Packets Received Number of packets received from any of 
node’s interfaces 

Packets Dropped Number of packets dropped by this node 
Packets 
Forwarded 

Number of packets forwarded by this 
node when acting as a router. 

Packet Delay Delay between the time a packet is 
received and the time it is forwarded. 

Sending rate Transmission rate in bytes/s 
Receiving rate Receiving rate in bytes/s 
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12.7 Link Statistics 
Statistic Description 
Snapshot Minimal/Average/Maximum values of the statistics collected 

as defined in this table. 
Instant 
These statistics represent 
the value for a given 
window of time during 
the simulation. The 
default interval time 
between two 
measurements is 1 
second. 

Packets Sent Number of packets sent across this link 
Packets Received Number of packets received across this 

link 
Packets Dropped Number of packets dropped over this link 
Queuing Delay Delay to transmit the packet  
Transmission 
Delay 

Delay between the time a packet is put in 
the transmission queue and the time it is 
received by the peer node. 

Sending Rate Transmission rate in bytes/s 
Receiving Rate Receiving rate in bytes/s 
Offered Load Data rate entering the transmission queue 

in bytes/s 
Cumulative 
These statistics represent 
the measurement 
collected from the 
beginning of the 
simulation. 

Packets Sent Number of packets sent across this link 
Packets Received Number of packets received across this 

link 
Packets Dropped Number of packets dropped over this link 
Queuing Delay Delay to transmit the packet  
Transmission 
Delay 

Delay between the time a packet is put in 
the transmission queue and the time it is 
received by the peer node. 

Sending Rate Transmission rate in bytes/s 
Receiving Rate Receiving rate in bytes/s 
Offered Load Data rate entering the transmission queue 

in bytes/s 
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12.8 Application Statistics 
Statistic Description 
Instant 
These statistics represent 
the value for a given 
window of time during 
the simulation. The 
default interval time 
between two 
measurements is 1 
second. 

Packets Sent Number of packets sent from any of the 
end points 

Packet Received Number of packets received from any of 
the end points 

Delay Delay between the time it is generated by 
the application on the transmitter side and 
the time it is received successfully on the 
received side. 

Jitter Packet jitter for the packets received. 
Sending Rate Transmission rate in bytes/s 
Receiving Rate Receiving rate in bytes/s 

Cumulative 
These statistics represent 
the measurement 
collected from the 
beginning of the 
simulation. 

Packets Sent Number of packets sent from any of the 
end points 

Packet Received Number of packets received from any of 
the end points 

Delay Delay between the time it is generated by 
the application on the transmitter side and 
the time it is received successfully on the 
received side. 

Jitter Packet jitter for the packets received. 
Sending Rate Transmission rate in bytes/s 
Receiving Rate Receiving rate in bytes/s 

12.9 Traffic Flows Statistics 
See section 12.8. 
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13 Versions and Compatibility 
 
The GUI is only compatible with the appropriate version of the simulation server and its 
associated model. Attempting to use the GUI with a server running a different version of 
code will cause an error and their communications will be aborted. 
 
If the client attempts to interact with a server that is running an incompatible version, a 
pop-up error message will be shown and the operation will be aborted. See example in 
Figure 102. 
 

 
Figure 102 - An Example of an Incompatible Server Version Message 
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14 Shortcut Keys/Combinations 
 
The following list shows the shortcut keys or key-combinations that are mapped to 
specific functions in the GUI application: 
 
• Ctrl+F: Open the “Search” window. 
• Ctrl+G: Launch the “Audio Trace Generator” tool. 
• Ctrl+L: Open the “VizNet Properties” window. 
• Ctrl+M: Switch between design mode and read-only mode. 
• Ctrl+N: Open the “New Project” window to create a new project. 
• Ctrl+O: Open an existing project by bringing up a browser window. 
• Ctrl+P: In design mode, open the “Project Properties” window. 
• Ctrl+R: In design mode, execute the simulation run with the server. 
• Ctrl+S: Save the current project. 
• Ctrl+W: Close the current project. 
• Ctrl+Y: Redo the last edit action. 
• Ctrl+Z: Undo the last edit action. 
• Shift+F1: Invoke the Help Content window. 
• F1: Open the documentation for the GUI. 
• F12: Save the current project to a different directory, to a different name or both. 
 
The following list shows the shortcut keys or key-combinations that are mapped to 
specific functions in the Audio Trace Generator tool: 
 
• Ctrl+N: Open the “New Project” window to create a new project. 
• Ctrl+O: Open an existing project by bringing up a browser window. 
• Ctrl+S: Save the current project. 
• F1: Open the documentation for the Audio Trace Generator tool. 
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15 Acronyms 
CBR Constant Bit Rate 
DNS Domain Name System (IETF RFC 1035) 
FTP File Transfer Protocol 
GPS Global Positioning System 
GUI Graphical User Interface 
IETF Internet Engineering Task Force 
IP Internet Protocol 
ISSI Inter-RF Subsystem Interface (P25) 
JRE Java Runtime Environment 
P25 Project 25 
PDF Portable Document Format 
RF Radio Frequency 
RFC Request for Comments 
RFG Radio Frequency Gateway (P25) 
RFSS Radio Frequency Subsystem (P25) 
RTP Real-time Transport Protocol (IETF RFC 3550) 
SIP Session Initiation Protocol (IETF RFC 3261) 
SU Subscriber Unit (P25) 
TCL Tool Command Language 
TCP Transmission Control Protocol 
UDP User Datagram Protocol 
URL Uniform Resource Locator 
XML Extensible Markup Language 
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A Network Primer 

A.1 Networks and Their Compositions  
 

Networks physically consist of nodes connected by links; the nodes run applications that 
may generate traffic that is transmitted over the links or they may relay traffic from 
incoming links to outgoing links. The “Topology Configuration” panel contains the icons 
necessary to create the various objects for the network topology. 
 
NODES 
 
Nodes are either configured as routers or RFGs. 
 

 Use the “Router” icon to create IP routers for the network topology. The address 
parameter is required to configure a router for the topology. 
 

 Use the “RFG” icon to create RFGs for the network topology. A RFG is an IP 
router that has its ISSI parameters configured (e.g., maximum RTP resources, maximum 
RF resources and registration lifetime). 
 
LINKS 
 
The connections between nodes are called links. Duplex and Simplex links are supported. 
 

 Use the “Duplex link” icon to create duplex links between nodes for the 
network topology. Duplex links permit transmission of data in both directions between 
the nodes involved. 
 

 Use the “Simplex link” icon to create simplex links between nodes for the 
network topology. Simplex links permit transmission of data in only one direction 
between the nodes involved. 
 
P25 ISSI CONFIGURATION FUNCTIONS 
 
P25 ISSI configuration functions related to the RFG nodes are SU and the “talk” Group. 
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 Use the “SU” icon to create and configure individual subscriber units for the 
network topology. An SU can only be configured to have its “home” on one RFG. 
 

 Use the “Group” icon to create and configure “talk” groups for the network 
topology. A “talk” group can only be configured to have its “home” on one RFG. 
 
APPLICATIONS 
 
A network carries calls or applications. P25 defines two types of calls: SU-to-SU call and 
Group call. The GUI also supports a set of applications designed to simulate specific IP 
traffic. Calls need to be properly configured in order to generate network traffic. If calls 
are not properly defined, then their activities and traffic statistics will not be generated for 
the network. 
 

 Use the “SU-to-SU call” icon to create SU to SU calls. These applications 
define which SU originates the call; which SU receives the call; the start time and stop 
time; and some P25 specific parameters (e.g., which device transmits the data first, 
whether availability check is requested or not). Some voice application parameters may 
be configured as well (e.g., mean spurt duration, mean spurt interval and number of 
IMBE blocks per P25 ISSI RTP packet). Audio files may also be configured and used as 
the traffic generators for the call. 
 

 Use the “Group call” icon to create “talk” group calls. These applications define 
which SU originates the call; the talk group of the call; the start time and stop time; and 
some P25 specific parameters (e.g., whether it is a confirmed or unconfirmed call). Some 
voice application parameters may be configured as well (e.g., mean spurt duration, mean 
interval and number of IMBE blocks per P25 ISSI RTP packet). Audio files may also be 
configured and used as the traffic generators for the call. 
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 Use the “IP traffic” icon to create Internet Protocol traffic applications. IP 
traffic applications simulated by the GUI include the constant bit rate (CBR) traffic 
model, the file transfer protocol (FTP) traffic model and the exponential traffic model. 
These applications allow for simulating traffic flow between two nodes using their 
respective IP traffic models; they define the source node, the destination node, the start 
and stop times, the transport protocol to use (UDP or TCP) and the related parameters for 
the transport protocol. 

A.2 Creating a Network  
Use the icons in the “Topology Configuration” panel to create a network topology. 
 
Step 1) Create a node 
 
Click on one of the “Nodes” icon (e.g., RFG) in the “Topology Configuration” panel (the 
icon will turn to a slightly darker gray); move the pointer to the “Topology” panel (the 
pointer will become the selected icon as it passes within the “Topology” panel’s canvas 
area), click again in the “Topology” panel’s canvas area to place the node at the desired 
location. The node’s configuration window will appear for configuration purposes. See 
Figure 103. 
 

 
Figure 103 - Node Configuration Window (Basic Configuration Tab) 

 
ACTIONS: 
• Enter a unique name for the node; it must be unique for the whole network topology. 
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The acceptable values are alphanumeric (i.e., a..z, A..Z, 0..9) and the ‘_’ character 
is also allowed. The name must begin with a letter and be at least two characters 
in length. 

• Enter a description to describe this node. 
• To change the location of the node using the configuration window, enter the 

appropriate values for the longitude or latitude parameters. 
The acceptable values are zero through the maximum X coordinate and zero 
through the maximum Y coordinate. 

The alternative way to relocate a node is to click on the node within the canvas area 
and drag the node to its new location on the canvas; its coordinates will change 
accordingly. 

• Enter an appropriate address for the node if the system generated address is not 
acceptable. Note that addresses must be unique for the whole network topology. 

• To change the “Visual parameters”: 
1) Use the “Browse…” button to select an icon from the available list. 
2) Select the “Font” from the list. 
3) Select the font “Size” from the list. 

• Select the “ISSI configuration” tab to configure ISSI parameters. See Figure 104. 
 

 
Figure 104 - Node Configuration Window (ISSI Configuration Tab) 

 
ACTIONS: 
• Enter the Wide Area Communications Network (WACN) identification (ID) for the 

node. This is a 5HEX-DIGIT value. 
The acceptable range of values is 0 to 1048575 (i.e., 0x00000 to 0xFFFFF). For 
hexadecimal values, precede the digits with the string “0x” (i.e., zero and the 
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lower case ‘x’ character). The number used for the hexadecimal value must be 
five digits long. 

• Enter the System identification (ID) for this node. This is a 3HEX-DIGIT value. 
The acceptable range of values is 0 to 4095 (i.e., 0x000 to 0xFFF). For 
hexadecimal values, precede the digits with the string “0x” (i.e., zero and the 
lower case ‘x’ character). The number used for the hexadecimal value number 
must be three digits long. 

• Enter the Radio Frequency Subsystem (RFSS) identification (ID) for this node. This 
is a 2HEX-DIGIT value. 

The acceptable range of values is 0 to 255 (i.e., 0x00 to 0xFF). For hexadecimal 
values, precede the digits with the string “0x” (i.e., zero and the lower case ‘x’ 
character). The number used for the hexadecimal value number must be two digits 
long. 

• The “RFSS identifier” is automatically generated using the format: “RFSS 
ID”.”System ID”.”WACN ID” as specified in TIA-102.BACA-A, section 3.4.1.1. 

• Enter the maximum Real-time Transport Protocol (RTP) resources available. 
The acceptable range of values is 0 to 2,147,483,647 (231-1). 

• Enter the maximum Radio Frequency (RF) resources available. Radio Frequency 
resources are equivalent to radio frequency channels. It requires one Radio Frequency 
resource to support one call. 

The acceptable range of values is 0 to 2,147,483,647 (231-1). 
• Check the “Mute capable” checkbox if the RFG is required to mute when losing 

transmissions. 
• Enter the appropriate “Registration lifetime” value. 

The acceptable range of values is 0 to 2,147,483,647 (231-1). 
• Enter the appropriate “Availability check delay” value; this is the time the allotted 

time that the RFSS has to carry out an availability check. 
The acceptable range of values is 0 to 2,147,483,647 (231-1). 

• Enter the appropriate “Tu2uhangtime” value; this is the maximum time interval 
during which there is no voice activity among RFSSs participating in an SU-to-SU 
call, before the call is released. 

The acceptable range of values is 0 to 2,147,483,647 (231-1). 
 
Step 2) Repeat step 1 to create at least one other node for the network topology. 
 
Step 3) Connect at least two of the nodes with a link. Click on a link icon (e.g., simplex 
or duplex) from the “Topology Configuration” panel; in the canvas area, single click on 
the first node then move to the second node and single click again to link them. Once the 
link is completed, the “Link Configuration” window will be displayed for configuration 
purposes; enter the appropriate values for the link’s properties. See Figure 105. 
 
NOTE: If there are no links between the nodes or if there are other issues such as the 
simplex links not allowing for packet delivery then a simulation error will occur. 
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Figure 105 - Link Configuration Window 

 
ACTIONS: 
• Enter an appropriate description for the link. 
• Enter a bandwidth. 

The acceptable range of values is zero (0) to 9,999,999.  
• Enter a delay time. 

The acceptable range of values is zero (0) to 9,999,999. 
• Select a queue type or accept the default (Drop tail). 
• Enter a queue size or accept the default. 

The acceptable range of values is 0 to 2,147,483,647 (231-1). 
• Enter the link loss rate, the loss unit (Packet or Byte), and select a random function 

and its parameters using the “Select Function” button. 
• To change the “Visual parameters”: 

1) Enter an appropriate value for the line width (a value between 0 and 
9,999,999). 

2) Check/Uncheck the option to show load animation. 
3) Check/Uncheck the option to indicate when the link is broken. 
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Step 4) In order to create user activities on the network, either groups or subscriber units 
must be added to the network. 
 
NOTE: If the network is to support groups, it is best to create the groups first then the 
subscriber units so that the subscriber units can be configured to be associated with a 
group upon its creation. If the subscriber unit is created first, then its configuration 
window will have to be revisited in order to associate that SU with a group. 
 
Step 4a) Configure groups (if necessary) by using the “Group Configuration” window. 
See Figure 106. 
 

 
Figure 106 - Group Configuration Window 

 
ACTIONS: 
• Enter a unique name for the group; it must be unique for the whole network topology. 

The acceptable values are alphanumeric (i.e., a..z, A..Z, 0..9) and the ‘_’ character 
is also allowed. The name must begin with a letter and be at least two characters 
in length. 

• Select an RFSS from the available list for this group’s home. 
• Enter a Group ID. This is a 4HEX-DIGIT value. 

The acceptable range of values is 0 to 65535 (i.e., 0x0000 to 0xFFFF). For 
hexadecimal values, precede the digits with the string “0x” (i.e., zero and the 
lower case ‘x’ character). The number used for the hexadecimal value must be 
four digits long. 
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• The subscriber group identification (SGID) is automatically generated using the 
WACN and system ID from the “Home RFSS” and this group’s ID. 

• Enter an appropriate description for this group if applicable. 
• Select the “Access permission” to allow/disallow non-emergency calls. 
• Select an appropriate priority from this group; this is used when this group competes 

against other groups on calls. 
• Select if emergency calls will be supported. 
• Select if resource preemption will be supported for emergency calls. 
• Enter the “Hang time” for the RF resources (a value of 0 indicates a transmission 

trunked call, values greater than 0 indicate a message trunked call). 
• Enter the “Confirmed call setup time” to define the maximum time that the RFG will 

hold the first PTT spurt if not all required resources are available to set up the call. 
• Select the appropriate “Interrupt mode” to define how calls are interrupted for this 

group (if applicable). 
• Enter the appropriate “Tgchhangtime” or accept the default. (See TIA-102.BACA-A, 

Annex A, Table 38 on page 328: “Maximum time interval (i.e., ISSI hang time) 
during which there is no voice activity over the ISSI among the RFSSs participating 
in a group call, which when exceeded will entail group call release.”) 

The acceptable range of values is 0 to 2,147,483,647 (231-1). 
 
NOTE: The “Announcement group” parameter shown is currently not implemented. 
 
Step 4b) Use the “SU Configuration” window to configure SUs. See Figure 107. 
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Figure 107 - SU Configuration Window (Basic Configuration Tab) 

 
ACTIONS: 
• Enter a unique name for the subscriber unit; it must be unique for the whole network 

topology. 
The acceptable values are alphanumeric (i.e., a..z, A..Z, 0..9) and the ‘_’ character 
is also allowed. The name must begin with a letter and be at least two characters 
in length. 

• Select an RFSS from the available list for this SU’s home RFSS. 
• Enter a user identifier (UID) to uniquely indentify this SU. 

The acceptable range of values is 0 to 16777215 (224-1) (i.e., 0x000000 to 
0xFFFFFF). For hexadecimal values, precede the digits with the string “0x” (i.e., 
zero and the lower case ‘x’ character). The number used for the hexadecimal 
value must be six digits long. 

• The subscriber unit identification (SUID) is automatically generated using the WACN 
and system ID from the “Home RFSS” and this SU’s ID. 

• Enter an appropriate description for this SU if applicable. 
• Select an appropriate “System access permission”. 
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• Select an appropriate “Group call capability”. 
• Select an appropriate “Unit-to-Unit call permission” and its associate priority. 
• Select an appropriate “Availability check”. 
• Select an appropriate “Call set-up preference”. 
• Select a “Group affiliation” if applicable. 

NOTE: The SU can only be associated with one of the previously defined groups. 
The SU’s configuration window can be recalled to associate the SU to another 
group if necessary. 

 
Click the “Movement configuration” tab to continue with the SU’s configuration. The 
“Movement configuration” panel allows for the configuration of RFSS registration and 
deregistration. These “movements” allow the SU to attach and move among the RFSSs. 
See Figure 108. 
 
NOTE: The SU can only be registered with one RFSS at a time. 

 

 
Figure 108 - SU Configuration Window (Movement Configuration Tab) 
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ACTIONS: 
• Use the “Add movement” button to create and add entries to the movement table.  
• For each entry, enter an appropriate time (in seconds) greater than zero for when this 

action is to occur in the simulation. 
The acceptable range of values is 1 to 2,147,483,648. 

• For each entry, select an appropriate serving RFSS from the pull-down list. 
• For each entry, select the appropriate action (register or deregister). 
 
NOTE: The SU must be registered with a serving RFSS in order to make or receive calls. 
 
To simulate a movement, create another entry and register the SU to a different RFSS; be 
sure to make the time for the new entry greater than the time of the old entry. 
 
NOTE: Since the SU cannot be registered with more than one RFSS, it will be 
automatically deregistered from its previous RFSS in order to register with the new RFSS. 
 
Step 5) Once SUs and groups have been created for the network topology; the following 
applications can be created: Group calls, bulk group call, unit-to-unit calls (SU-to-SU) 
and bulk unit-to-unit calls. 
 
Step 5a) Configuring group calls 
 

Select the “Group call” icon  from the “Topology Configuration” panel to bring 
up the “Group Call Configuration” window. See Figure 109. 
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Figure 109 - Group Call Configuration Window (Single Group Call) 

 
ACTIONS: 
• Select the “Single Call” radio button to specify a single group call application. 
• Enter a unique name for the group call; it must be unique for the whole network 

topology. 
The acceptable values are alphanumeric (i.e., a..z, A..Z, 0..9) and the ‘_’ character 
is also allowed. The name must begin with a letter and be at least two characters 
in length. The name cannot end with “_XX” where “XX” is an arbitrary length 
number. 

• Select a group from those previously defined via the pull-down options. 
• Select the SU that will initiate the call from those previously defined via the pull-

down options. 
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• Enter an appropriate start time. 
The acceptable range of values is zero (0) or larger and must be smaller than the 
stop time. 

• Enter an appropriate stop time. 
The acceptable range of values is greater than zero (0) to 9,999,999 and must be 
larger than the start time. 

• Enter an appropriate description for this call if applicable. 
• Choose an appropriate “Group Call Type” (Unconfirmed or Confirmed). 
• Select an appropriate priority for the call via the pull-down options. 
• Use the checkbox to indicate if the call is an emergency or non-emergency group call. 
• Enter the appropriate values for “Mean Spurt Duration” and “Mean Spurt Interval”. 

Acceptable values are zero to 9,999,999. 
• Select the appropriate “Number of IMBE Blocks per Packet” via the pull-down 

options (1, 2, or 3). 
• The “Audio Configuration” button can be used to incorporate audio trace files from 

previously created audio projects. The use of audio trace files will preempt the “Mean 
Spurt Duration” and “Mean Spurt Interval” values. See section B for more details. 

 
Step 5b) Configuring bulk group calls 
 

Select the “Group call” icon  from the “Topology Configuration” panel to bring 
up the “Group Call Configuration” window. See Figure 110. 
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Figure 110 - Group Call Configuration Window (Bulk Group Call) 

 
ACTIONS: 
• Select the “Bulk Call” radio button to specify a bulk group call application. See 

Figure 89. 
• Enter a unique name for the bulk group call; it must be unique for the whole network 

topology. 
The acceptable values are alphanumeric (i.e., a..z, A..Z, 0..9) and the ‘_’ character 
is also allowed. The name must begin with a letter and be at least two characters 
in length. 

• Select a group from those previously defined via the pull-down options. 
• Enter an appropriate start time. 
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The acceptable range of values is zero (0) or larger and must be smaller than the 
stop time. 

• Enter an appropriate stop time. 
The acceptable range of values is greater than zero (0) to 9,999,999 and must be 
larger than the start time. 

• Use the “Select Interval Function” button to select an appropriate interval function 
and its parameters. 

• Use the “Select Duration Function” button to select an appropriate duration function 
and its parameters. 

• Enter an appropriate description for this call if applicable. 
• Choose an appropriate “Group Call Type” (Unconfirmed or Confirmed). 
• Select an appropriate priority for the call via the pull-down options. 
• Use the checkbox to indicate if the call is an emergency or non-emergency group call. 
• Enter the appropriate values for “Mean Spurt Duration” and “Mean Spurt Interval”. 

Acceptable values are zero to 9,999,999. 
• Select the appropriate “Number of IMBE Blocks per Packet” via the pull-down 

options (1, 2, or 3). 
 
Step 5c) Use the “SU to SU Call Configuration” window to configure SU-to-SU calls. 
See Figure 111. 
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Figure 111 - SU to SU Call Configuration Window (Single Call) 

 
ACTIONS: 
• Select the “Single Call” radio button to specify a single SU-to-SU call application. 
• Enter a unique name for the SU-to-SU call; it must be unique for the whole network 

topology. 
The acceptable values are alphanumeric (i.e., a..z, A..Z, 0..9) and the ‘_’ character 
is also allowed. The name must begin with a letter and be at least two characters 
in length. The name cannot end with “_XX” where “XX” is an arbitrary length 
number. 

• Select the SU that will initiate this call from those previously defined via the pull-
down options. 

• Select the SU that will receive this call from those previously defined via the pull-
down options. 

• Enter an appropriate start time. 
The acceptable range of values is zero (0) or larger and must be smaller than the 
stop time. 

• Enter an appropriate stop time. 
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The acceptable range of values is greater than zero (0) to 9,999,999 and must be 
larger than the start time. 

• Enter an appropriate description for this call if applicable. 
• Select the appropriate “Initial Transmitter” (Calling SU or Called SU), this SU will be 

transmitting the initial data for the call. 
• Select the appropriate “Preference” of either no availability check or availability 

check. 
• Use the checkbox to indicate if the call is an emergency or non-emergency call. 
• Select the appropriate “Teardown Initiator” (Calling SU or Called SU), this SU will 

initiate the teardown of the call. 
• Enter the appropriate values for “Mean Spurt Duration” and “Mean Spurt Interval”. 

Acceptable values are zero to 9,999,999. 
• Select the appropriate “Number of IMBE Blocks per Packet” via the pull-down 

options (1, 2, or 3). 
• The “Audio Configuration” button can be used to incorporate audio trace files from 

previously created audio projects. The use of audio trace files will preempt the “Mean 
Spurt Duration” and “Mean Spurt Interval” values. See section B for more details. 

 
Step 5d) Use the “SU to SU Call Configuration” window and enabling the “Bulk Call” 
option to configure bulk SU-to-SU calls. See Figure 112. 
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Figure 112 - SU to SU Call Configuration Window (Bulk Call) 

 
ACTIONS: 
• Select the “Bulk Call” radio button to specify a bulk SU-to-SU call application. 
• Enter a unique name for the bulk SU-to-SU call; it must be unique for the whole 

network topology. 
The acceptable values are alphanumeric (i.e., a..z, A..Z, 0..9) and the ‘_’ character 
is also allowed. The name must begin with a letter and be at least two characters 
in length. 

• Use the “Select SUs” button to select the SUs to be included in the bulk call. 
• Enter an appropriate start time. 

The acceptable range of values is zero (0) or larger and must be smaller than the 
stop time. 

• Enter an appropriate stop time. 
The acceptable range of values is greater than zero (0) to 9,999,999 and must be 
larger than the start time. 

• Use the “Select Interval Function” button to select an appropriate interval function 
and its parameters. 
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• Use the “Select Duration Function” button to select an appropriate duration function 
and its parameters. 

• Enter an appropriate description for this call if applicable. 
• Select the appropriate “Initial Transmitter” (Calling SU or Called SU), this SU will be 

transmitting the initial data for the call. 
• Select the appropriate “Preference” of either no availability check or availability 

check. 
• Use the checkbox to indicate if the call is an emergency or non-emergency call. 
• Select the appropriate “Teardown Initiator” (Calling SU or Called SU), this SU will 

initiate the teardown of the call. 
• Enter the appropriate values for “Mean Spurt Duration” and “Mean Spurt Interval”. 

Acceptable values are zero to 9,999,999. 
• Select the appropriate “Number of IMBE Blocks per Packet” via the pull-down 

options (1, 2, or 3). 
 
Step 6) Save the newly defined network 
 
From the main menu bar, select “File->Save” (Ctrl+S). 
 
Step 7) Run the simulation 
 
From the main menu bar, select “Project->Launch Simulation” or click on the icon 

 
 
Step 8) If the simulation run is successful, the results and statistics can be viewed in the 
“Statistics” Panel. 
  
Step 8a) If the simulation run is not successful, open the “FileViewer” window and select 
the “Log File” tab to view information about the failure. This information may be helpful 
for diagnosing the problem. 
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B Audio Traces 
If the simulation project does not contain any media file and the user elects to display the 
media window from the menu bar (Windows->Media), then the media window is 
presented with no media files to play, see Figure 113. 
 

 
Figure 113 - Media Window with no Media Files Available 
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If the simulation project contains one or more audio media files, then the media window 
contains the “Call List” and its related “User List”, see Figure 114. 
 

 
Figure 114 - Media Window with Media Files Available for Playback 

 
The following sections describe how media projects are created, how media files can be 
included to simulation projects and how to control the playback of the media files using 
the available control bars. 
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B.1 Creating Audio Projects  
From the main GUI window, select “Tools->Audio Trace Generator” to bring up the 
Audio Trace Generator (ATG) window as shown in Figure 115. The ATG contains a 
menu bar at the top; located under the menu bar are the “Audio File Control” buttons 
followed by the “Sound Graph” panel, the “Automatic Parsing Configuration” panel and 
the “Spurt Assignment” panel. Also see section 3.2.5.1. 
 

 
Figure 115 - Initial Screen of the Audio Trace Generator 

 
Select “File->New…” to bring up the “New Project” configuration window, see Figure 
116. For “Project Location”, use the “Browse” button to navigate to an appropriate folder 
for creating the new project; for “Audio File”, use the “Browse” button to select an audio 
file for the project; enter an appropriate description for the project then click the “OK” 
button to create the project. 
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Figure 116 - New Audio Project Configuration Window 

 
The Sound Graph panel will display the audio file’s signals accordingly, see Figure 117. 
Enter appropriate “Noise Threshold” and “Minimum Break Length” values then click the 
“Parse Audio” button to analyze and separate the audio signals into spurts (at least one 
spurt will be detected). 
 

 
Figure 117 - Audio Trace Generator with an Analyzed Audio File 

 
Select the spurt(s) in the “Unassigned Spurt(s)” subpanel and use the “Play Selected 
Spurt” button  to listen to the spurt(s). If necessary, readjust the “Noise Threshold” 
and “Minimum Break Length” values and reanalyze the audio file until the spurts are 
correctly separated. 
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Use the “Add New User” button  to create one or more users in order to assign the 
spurt(s) to the appropriate number of people in the audio file. Select the appropriate user 
tab in the “Users” subpanel; select the spurt(s) from the “Unassigned Spurt(s)” subpanel, 
then use the “Add Spurt” button to associate the spurt(s) with the appropriate user(s). See 
Figure 117. 
 
If a spurt is incorrectly associated with a user tab, then select the invalid spurt from that 
user’s tab and use the “Remove Spurt” button to disassociate that spurt with the user and 
move the spurt back to the “Unassigned Spurt(s)” subpanel. See Figure 118. 
 

 
Figure 118 - User Tab Containing an Invalid Spurt 

 
Use the “Remove the Selected User” button  along with the “Rename the Selected 
User” button  to delete or rename the user accordingly. 
 
Once all spurts are correctly associated with their users, use the “File->Save” menu 
option to save the audio project then use “File->Exit” to exit the ATG. The newly created 
audio project, i.e., its folder’s content, can now be used with simulation projects. 

B.2 Associating Audio Files with Simulation Projects  
The example described below is for a “Group” call; however the general procedure for 
associating audio projects with applications/calls from simulation projects is similar. 
 
From the main GUI window, select “File->Open Project…” to load a simulation project 
that requires the addition of audio media. Go into “edit” mode for the project and select 
the “Topology Configuration” tab, see Figure 119. 
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Figure 119 - Topology Configuration Tab Showing Applications 

 
Expand the “Topology->Applications” folder then right-click on an application/call that 
requires audio media; select the “Properties” option to configure that call and bring up its 
configuration window. In this example, a “Group” call is used, see Figure 120. 
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Figure 120 - SU to SU Call Configuration Window 

 
Select the “Audio configuration” button to bring up the “Audio Call Configuration” 
window, see Figure 121. 
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Figure 121 - Audio Call Configuration Window 

 
For each SU that is associated to an audio project such as the project described in section 
B.1; from the “Audio Parameters” drop-down options, select Project->Load (see Figure 
121) and navigate to the appropriate audio project and load it by selecting “Open” (see 
Figure 122). Notice that each audio project can only be loaded once but can be used 
multiple times for various subscriber units. 
 

 
Figure 122 - Open Audio Project file Window 
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Map each of the appropriate SUs (from the “List of SUs”) to their related user (from the 
audio project) by using the “Project” and “Source” drop-down options; the audio spurts 
were previously mapped to the users from the steps described in section B.1. Check the 
“Record Audio” checkbox if the audio that the selected SU hears is to be recorded (see 
Figure 123). 
 

NOTE: The recording of the audio that an SU hears is independent of the 
assignment of audio spurt(s) to that SU, i.e., an SU can record audio that it hears 
without having audio spurt(s) assigned to it, and vice versa. Also note that the 
recorded audio that the SU hears does NOT include the audio generated by that 
SU (i.e., the SU does not hear its own voice). 

 

 
Figure 123 - Mapping SUs to Users from Audio Projects 

 
Select OK in the “Audio Call Configuration” window to save the SU mappings, then 
select OK in the “Group Call Configuration” window to save its configuration. From the 
main window, select “File->Save” to save the simulation project. Select the “Launch 
simulation in the server” button to run the simulation project in the server. The server will 
then generate appropriate output files, and the GUI (client) will generate the resulting 
audio files based on the server’s output files. 

B.3 Playing Back Audio Files from Simulation Projects  
After loading a simulation project that contains media files for playback (see section B.1 
above for creating such a project), the media panel will load the list of available calls. 
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Figure 124 - Main Screen with a Simulation Project Containing Audio Files 

 
The “Action” button (1) has three modes, play/pause/resume (see section 4.5.1), to 
initiate playback of the simulation, select the play mode (see Figure 124). The media 
panel (2) contains the call selection list (3) that contains all calls related to the simulation 
project; the user selection list (4) contains all users mapped to each call; the confirm 
selection button (5) is used to select the media file to play. 
 
Once in play mode, the action button assumes the pause mode and the master control bar 
(1) shows the playback time line of the simulation project (see Figure 125); select the 
action button while it displays “Pause” to suspend playback. The media control bar (2) 
will be displayed only when the playback time line is in the time range of the media file, 
e.g., if the media file’s start time is 15 seconds into playback, then the media control bar 
will be displayed at 15 seconds and beyond during playback. 
 
Figure 125 shows the master time slider (3), it is used to control the project’s playback 
time position; the media time slider (4) can be used to select the media playback time 
position while the project’s time line is within the time range of the media file; the 
volume button  (5) and the media properties button  (6) are also shown. 
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Figure 125 - Main Screen during Playback of a Media File 

 
The media properties button  is used to bring up the “Media Properties” window to 
show characteristics of the media file; see Figure 126. 
 

 
Figure 126 - Media Properties Window 

 
During playback, the user may click on the master time slider or the media time slider to 
select specific playback time. From the pause mode, select the action button to resume 
playback. Select the stop button at any time to stop playback of the simulation project. 
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Selecting a specific call from the “Call List” then selecting a specific user from the “User 
List” then selecting the “Confirm Selection” button will result in playing back what that 
particular user heard during the prerecorded transmission (media file). Notice that the 
transmission of the user selected will not be heard but the other people’s transmissions 
will be heard, i.e., media file playback is heard in first person singular mode. 
 
Selecting a different media file can be done at any time during playback; after the 
“Confirm Selection” button is selected, the specified media file will begin playback 
immediately at the time indicated by the master control bar, but only if the media file’s 
time range is within the time range of the master time slider. The selection of a media file 
that is not within the time range of the master time slider is also allowed; once the master 
time slider is playing within the time range of that particular media file then that media 
file will begin to play automatically. 
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C Common Error/Warning Messages 
This appendix contains some common error messages along with their possible causes. 
 
1) 
 

 
 
Group Call Error: The topology does not have any SU assigned to a group 
 
Cause: There are no SUs that have been configured to use a talk group or there are no 
SUs created in the topology. 
 
2) 
 

 
 
SU Call Error: The topology does not have enough SUs to create a call 
 
Cause: There are no SUs defined or there is only one SU defined in the topology. 
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3) 
 

 
 
Group Call Error: The topology does not have any group configured 
 
Cause: No group has been configured for a node in the topology. 
 
4) 
 

 
 
Authentication error: Connection refused 
 
Cause: Unable to connect to the server to authenticate. 
 
5) 
 

 
 
Authentication error: Invalid user name or password 
 
Cause: An invalid user name and/or password were entered resulting in an authentication 
failure. 
 



 141 

6) 
 

 
 
Simulation Warning 
 
Cause: The simulation run terminated with an error on the server. Review the log of the 
simulation for more details. 
 
7) 
 

 
 
Invalid Scenario 
 
Cause: The server reported an invalid scenario for the project (i.e., the project’s 
configuration is malformed). Review the validation log in the “FileViewer” tab for more 
details. 
 
8) 
 

 
 
Invalid Media File 
 
Cause: The Media Player cannot find or open the specified media file. The project’s 
media file or files are missing. 
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9) 
 

 
 
Configuration Outdated 
 
Cause: The project’s configuration has changed since the last simulation was run with the 
server. If the user tries to view the results from the simulation (such as statistics) and 
changes have been made to the project then this message will be displayed. Rerun the 
simulation to resolve this pop-up message. 
 
10) 
 

 
 
Pending Simulation 
 
Cause: If the user tries to close a project after it has been submitted to the server for 
processing, and the server has not concluded its processing of the project then this 
message will be displayed. 
 
Note: If the simulation is running, closing the project will not stop the simulation on the 
server. When the project is reopened, the user will have the opportunity to check the 
status of the simulation; once the simulation is completed, the results can be accessed. 
This feature is useful for running large/long simulations. 
 
 



 143 

11) 
 

 
 
Simulation Playback Notice 
 
Cause: During the playback of a simulation (i.e., in read-only mode), the user chooses to 
switch to design mode causing this notice to be displayed. 
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D List of Software Tools 
Various Java technologies were used in developing the Graphical User Interface for 
Project 25, this section acknowledges what software products/packages were used in 
developing the GUI. Software packages that were involved with developing and 
supporting the GUI included but not limited to the following: 
 
• Cryptographic Provider: The Legion of the Bouncy Castle 

(http://www.bouncycastle.org) 
• Docking Windows: InfoNode (http://www.infonode.net) 
• Java (version 6): www.java.com 
• Java Audio Implementation: Tritonus (http://www.tritonus.org) 
• Java Chart Library: JFreeChart (http://www.jfree.org/jfreechart) 
• JavaAPIforKML: (http://labs.micromata.de/display/jak/Home) 
• JAXB: (http://java.sun.com/developer/technicalArticles/WebServices/jaxb) 
• Media Player: JMF (http://java.sun.com/javase/technologies/desktop/media/jmf) 
• NetBeans OpenIDE Libraries: (http://netbeans.org/features/platform) 
• Numerical Methods: (http://www-sfb288.math.tu-berlin.de/~jtem/numericalMethods) 
• Other Swing Extensions: (https://jxlayer.dev.java.net, 

http://fifesoft.com/rsyntaxtextarea) 
• PDF Generation: iText Java PDF library (http://www.lowagie.com/iText) 
• RSyntaxTextArea: (http://fifesoft.com/rsyntaxtextarea) 
• Swing Component Extensions: (https://swingx.dev.java.net) 
• TCL: www.tcl.tk 
• XML Parser: JDOM (http://www.jdom.org) 
• Xuggle Library: (http://www.xuggle.com) 
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E Trademarks 
InfoNode is a registered trademark of NNL Technology AB in Sweden. 
 
Google and Google Maps are registered trademarks of Google Inc. in the United States 
and other countries. 
 
Oracle and Java are registered trademarks of Oracle and/or its affiliates in the United 
States and other countries. 
 
Oracle and NetBeans are registered trademarks of Oracle and/or its affiliates in the 
United States and other countries. 
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